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Creating and Managing Projects

This chapter describe how to create, open, save, and customize a project. For 
information on how to manage source files, see “Managing Files” (page 25).


“Creating a Project” (page 1)


“Opening and Closing a Project” (page 4)


“Grouping Related Projects” (page 7)


“Setting Application Options” (page 12)


Creating a Project


This section describes how to create a new project.


Creating a Project


1. Choose Project>New.


2. In the panel that appears, choose the project’s type.


3. Enter the name of the project in the Name field.
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With one command, you can create a project that includes template source files, 
resource files, and makefiles.


1. Choose Project>New.
Project Builder displays the New Project panel.


2. In the panel that appears, choose the project’s type.
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Choose one of the following types from the Project Type pop-up menu.


Project Type Description


Application A stand-alone application with a graphic user interface. The 
project contains many files, including a sample source file, 
nib files for Rhapsody and Windows applications, and a 
makefile. 


Tool A server or command-line program without a graphic user 
interface. The project contains many files, including a sam-
ple source file and a makefile. 


Loadable Bundle A directory of resources, such as images, sounds, character 
strings, nib files, and dynamically loadable executable code, 
to be used by one or more applications. The project contains 
many files, including a sample source file, a nib file, and a 
makefile. 


Library A static or dynamic shared library. The project contains 
many files, including a sample source file and a makefile. 


Framework A bundle that contains a dynamic shared library plus re-
sources. The project contains many files, including a sample 
source file, a nib file, and a makefile. 


Palette A static Interface Builder palette—a palette with code that 
you must compile before it can be used. The project con-
tains many files, including a sample source file, a nib file, 
and a makefile


Legacy A project for which Project Builder doesn’t maintain the 
makefile. Use this when you have created your own make-
file. The project contains many sample source files. 


Note that you don’t have to use this project type whenever 
you want to have some control over the makefile. Instead, 
you can edit the Makefile.preamble or Makefile.postamble 
files.


Aggregate A collection of loosely related projects. See “Grouping 
Related Projects” (page 7).
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Generally, the only difference between project types is the kind of executable 
they produce. However, there are some important differences between 
applications and libraries (including frameworks). 


3. Enter the name of the project in the Name field.
After you press OK, Project Builder creates a directory that will hold all of the 
project’s code files and resource files. Project Builder adds several supporting 
files, such as project makefiles and templates that you can use to create source 
files, to that directory


Opening and Closing a Project


You open and close a project file in much the same was you’d open and close any 
file.


“Opening a Project” (page 4)


There are two ways to close a project. Either choose Close from the Project menu, or 
click the close box in the project’s window. Project Builder closes the project file and 
all opened source files that belong to the project. 


Opening a Project


1. Choose Project>Open.


2. Select the project. .
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You can open a project in much the same way you can open any other file. 


You can also open a project within the Workspace by double-clicking on the 
PB.project file.


1. Choose Project>Open.


2. Select the project.


■ If you’re using Yellow Box under Windows, select the PB.project file in the 
project directory. 


■ If you’re using Rhapsody, select the project folder itself. Selecting the 
PB.project file will open it as a text file, not a project file.


After you press OK, Project Builder opens the project and displays a project 
browser window for it.
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Changing a Project’s Name


 


1. Bring up Project Attributes display Project Inspector.


   

2. In the Project Name field, enter the new name.


By default, the project’s name is the name of the directory you chose when you 
created the project. Project Builder uses the same name for the executable or bundle 
that the project creates. If this isn’t the name you want to use, you can change it. 


1. Bring up Project Attributes display Project Inspector.
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In the project window, click the Inspector button . The Project Inspector 
panel appears. Choose Project Attributes from the pop-up menu at the top of the 
panel. The Project Attributes display appears.


        


Gr


 


7


2. In the Project Name field, enter the new name.
After you press Return, Project Builder now uses that name for the project and 
whatever end product the project creates.


Switching Between Open Projects


1. In the Load Projects window, click the project you want to work on.


In the Loaded Projects window, you can view all the projects that are open within 
Project Builder and select which one to work on.


1. In the Load Projects window, click the project you want to work on.
To see the Loaded Projects window, choose Loaded Projects from the Tools 
menu. After you click a project, its window comes to the front.


ouping Related Projects


If you have many projects that relate to each other, you can organize them as a 
single project in Project Builder. You can group related projects into a single project 
in two ways: by creating subprojects within a regular project or within an aggregate 
project:


If the subproject’s build result is part of the main project’s build result, create a 
subproject within a regular project.
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If the main project does not use the build results from the subprojects, but you want 
to group several projects together as a convenience, create subprojects within an 
aggregate project


To have all subprojects be listed in the top level of the browser (rather than under 


  

Subprojects), set the preference on the Miscellaneous display of the Preferences 
panel.


For information on the different ways to include a subproject within a project, see 
these sections:


“Using Subprojects in Regular Projects” (page 8)


“Using Aggregate Projects” (page 9)


For information on how to add new or existing subprojects to a project, see these 
sections:


“Creating a New Subproject” (page 9)


“Adding an Existing Project as a Subproject” (page 11)


Using Subprojects in Regular Projects


When you create a subproject within a regular project, the subproject’s build result 
(executable or bundle) is included in the build result of the main project. If the main 
project produces a bundle as its build result, the subproject’s executable or bundle 
is placed inside the main project’s bundle. Component subprojects produce an 
object file that is linked with the main project’s executable. A component’s resources 
are merged into the resource directory of the main project. 


For example, if you’re creating an application named MyApp and the application 
uses a command-line tool named aTool, you can include aTool project as a 
subproject of the MyApp project. When you build MyApp, aTool is built as well. 
After all of the code in both projects has been compiled and linked, Project Builder 
creates a directory (bundle) named MyApp.app. That directory contains aTool as 
well as the MyApp’s executable and resources.
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Using Aggregate Projects


 


If you have several projects whose executables don’t need to be tied to each other 
but you want to group them together as a convenience, create an aggregate project 
and include those projects as subprojects in the aggregate. 
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The aggregate project itself produces no executable or bundle. Its only purpose to 
group other projects together. Any project, even applications and frameworks, can 
be a subproject of an aggregate. 


For example, suppose you’ve created several tools to test a framework that you’re 
working on. If you want to manage all of these projects as a single unit, you can 
create an aggregate project and include the tools and the framework as subprojects 
of the aggregate.


Creating a New Subproject


1. Choose Project>New Subproject.  


2. Choose the subproject’s type.


3. In the Name field, enter the subproject’s name.  


You can easily create a new subproject, which can contain all the files a project 
would but is completely contained within another project.


1. Choose Project>New Subproject.
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A New Subproject panel appears. 


 


2. Choose the subproject’s type.


 


From the Type pop-up menu, choose one of the following types:


    

3. In the Name field, enter the subproject’s name.
After you press OK, Project Builder creates a subdirectory within the main 
project’s directory that will hold all of the subproject’s code files and resource 
files. Project Builder adds several supporting files, such as project makefiles and 
templates that you can use to create source files, to that subdirectory


Subproject Type Description


Component A convenient grouping of related files within a 
project. It’s not meant to stand alone as a tool, frame-
work, palette, or library, nor is it meant to dynamical-
ly loaded like a bundle. 


Loadable Bun-
dle


A directory of resources, such as images, sounds, 
character strings, nib files, and dynamically loadable 
executable code, to be used by one or more applica-
tions. The project contains many files, including a 
sample source file, a nib file, and a makefile. 


Tool A server or command-line program without a graph-
ic user interface. The project contains many files, in-
cluding a sample source file and a makefile. 


Framework A bundle that contains a dynamic shared library plus 
resources. The project contains many files, including a 
sample source file, a nib file, and a makefile. 


Library A static or dynamic shared library. The project con-
tains many files, including a sample source file and a 
makefile. 


Palette A static Interface Builder palette—a palette with code 
that you must compile before it can be used. The 
project contains many files, including a sample source 
file, a nib file, and a makefile
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Adding an Existing Project as a Subproject


 


1. Choose Project>Add Subproject.  
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2. Select the project.


You can add an existing project to another project as a subproject. This is helpful if 
you want to manage several related applications as one project.


This procedure creates a copy of the selected project and places the copy in the main 
project’s directory. If you want to create a project which several different projects 
share, see “Grouping Related Projects” (page 7).
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1. Choose Project>Add Subproject.


 


An Add Subprojects panel appears. 


 


2. Select the project.


     


Se


    

■ If you’re using Yellow Box under Windows, select the PB.project file in the 
project directory. 


■ If you’re using Rhapsody, select the project folder itself. Selecting the 
PB.project file will open it as a text file, not a project file. Note that the Name 
field remains empty.


After you press OK, Project Builder creates a copy of the selected project and 
places the copy in the main project’s directory


tting Application Options


Project Builder gives you several ways to customize your Application project and 
how it’s built.


“Setting the Language” (page 12)


“Setting the Application Class” (page 14)


“Choosing Options for Different Platforms” (page 15)


“Choosing the Main Nib File” (page 16)


“Setting the Application Icon” (page 18)


“Setting Document Icons” (page 19)


“Setting System-Defined Icons” (page 22)


“Setting the Help File” (page 23)


Setting the Language


1. In the Project Attributes display of the Project Inspector, enter the name of the 
language in the Language field.
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1. In the Project Attributes display of the Project Inspector, enter the name of the 
language in the Language field.
To display the Project Attributes display of the Project Inspector, choose 
Tools>Inspector, and choose Project Attributes from the pop-up menu at the top 
of the panel that appears.


In the Language field, enter the English name for the language. The default 
language is English.


Project Builder creates an .lproj subdirectory for the language specified if one 
doesn’t already exist. When you view the interface files for your project, only the 
files for this language appear. And when you turn on the Localizable Resource 
option for a file in the File Attributes display, Project Builder places the file in the 
.lproj subdirectory of the language that’s specified here.
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For more information on how to localize an application, see “Localizing an 
Application—Summary of Steps” (page 87).


    

Setting the Application Class


1. In the Project Attributes display of the Project Inspector, enter the name of the 
class in the Application Class field.


If you use a custom subclass of NSApplication, enter its name in the Application 
Class field. When your application is launched, it creates an instance of this class. 
The default value is NSApplication.
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1. In the Project Attributes display of the Project Inspector, enter the name of the 
class in the Application Class field.


 


To display the Project Attributes display of the Project Inspector, choose 
Tools>Inspector, and choose Project Attributes from the pop-up menu at the top 
of the panel that appears.
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Choosing Options for Different Platforms


1. In the Project Attributes display of the Project Inspector, choose the platform from 
the pop-up menu.
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Project Builder lets you select different settings for several different options 
depending on which platform you’re developing for. For example, your application 
can have a different icon file for Windows and Rhapsody. 


 


1. In the Project Attributes display of the Project Inspector, choose the platform from 


            

the pop-up menu.
To display the Project Attributes display of the Project Inspector, choose 
Tools>Inspector, and choose Project Attributes from the pop-up menu at the top 
of the panel that appears.


Choose the platform from the pop-up menu in the middle of the panel.


Project Builder saves the settings for the previous platform and restores the 
settings for the selected platform.


These are the settings affected:


■ Main nib File, described in “Choosing the Main Nib File” (page 16)


■ Help File, described in “Setting the Help File” (page 23)


■ Application Icon, described in “Setting the Application Icon” (page 18)


■ Document Icons, described in “Setting Document Icons” (page 19)


Choosing the Main Nib File


1. In the Project Attributes display of the Project Inspector, enter the name of the nib 
file in the Main nib File field.
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1. In the Project Attributes display of the Project Inspector, enter the name of the nib 
file in the Main nib File field.
To display the Project Attributes display of the Project Inspector, choose 
Tools>Inspector, and choose Project Attributes from the pop-up menu at the top 
of the panel that appears.


Enter the name of the project’s main nib file in the Main nib File field. This is 
generally the nib file with your application’s menus and main windows. 


You can choose different main nib files for different platforms. See “Choosing 
Options for Different Platforms” (page 15).
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Setting the Application Icon


 


1. In the Project Attributes display of the Project Inspector, click the Application Icon 
field.


        

2. Enter the name of the icon file.


This method explains how to assign an icon to an application. This is the icon that 
the user sees in the Workspace Manager.


You can choose different application icons for different platforms. See “Choosing 
Options for Different Platforms” (page 15).


1. In the Project Attributes display of the Project Inspector, click the Application Icon 
field.
To display the Project Attributes display of the Project Inspector, choose 
Tools>Inspector, and choose Project Attributes from the pop-up menu at the top 
of the panel that appears.


2. Enter the name of the icon file.
There are two ways to enter the file name:


■ Drag the icon file from the Workspace Manager to the icon well. Project 
Builder adds the file to the project, if necessary, and enters the name of the 
file in the Application Icon field 
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■


 


Type the icon file’s name in the field. Project Builder displays the icon in the 
icon well. Use this method only if you’ve already added the icon file to the 
project.
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Setting Document Icons


1. In the Project Attributes display of the Project Inspector, click Add.


2. Enter the icon file’s name.


3. In the Extension field of the Document Icons table, type the file extension that this 
icon represents.  


If your application creates documents of a unique type or if it will be the default 
application for an existing type, you should assign an icon for that document type. 


If your application reads documents of a certain type, but cannot write them, you 
should add the extension for the document type to the Document Icons table as 
well. See “Setting System-Defined Icons” (page 22).


You can choose different document icons for different platforms. See “Choosing 
Options for Different Platforms” (page 15).


This method lets you easily add an icon file to the project and assign it to a 
document type.
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1. In the Project Attributes display of the Project Inspector, click Add.


 


To display the Project Attributes display of the Project Inspector, choose 
Tools>Inspector, and choose Project Attributes from the pop-up menu at the top 
of the panel that appears.


    

After you click Add, a new row appears in the Document Icons table. The 
insertion point is in the Icon Name field.


2. Enter the icon file’s name.
There are two ways to do this:


■ Drag the icon file from the Workspace Manager into the icon well. Project 
Builder adds the file to the project and enters the name of the file in the Icon 
Name field of the Document Icons table
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■ In the Icon name field of the Documents Icon table, type the icon file’s name, 
and press Return. Project Builder displays the icon in the icon well. Use this 
method only if you’ve already added the icon file to the project.


3. In the Extension field of the Document Icons table, type the file extension that this 
icon represents.
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The icon now appears for any file with that extension.


Setting System-Defined Icons


1. In the Project Attributes display of the Project Inspector, click Add.


2. In the Extension field of the Document Icons Table, type the file extension.  


In addition to listing the document types that your application can create, the 
Document Icons table should list the document types that your application can read 
but cannot create. For example, if your application can open RTF files and translate 
them into its own unique document type, you should list the RTF extension in this 
table


1. In the Project Attributes display of the Project Inspector, click Add.
To display the Project Attributes display of the Project Inspector, choose 
Tools>Inspector, and choose Project Attributes from the pop-up menu at the top 
of the panel that appears.


After you click Add, a new row appears in the Document Icons table.


2. In the Extension field of the Document Icons Table, type the file extension. 
Your application can now open documents of this type.
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Setting the Help File


 


1. In the Project Attributes display of the Project Inspector, place the insertion point 
in the Help File field.
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2. Drag the help file from the Workspace Manager to the icon well.


Your application can have a comprehensive help file, which it opens when a user 
selects Help from the Apple menu. Just enter the help file’s name in the Help File 
field, or follow the procedure below. 


Note that if the Help File field is blank, Project Builder assumes the file has the same 
name as the project (minus any extension).


You can choose different help files for different platforms. See “Choosing Options 
for Different Platforms” (page 15).


1. In the Project Attributes display of the Project Inspector, place the insertion point 
in the Help File field.
To display the Project Attributes display of the Project Inspector, choose 
Tools>Inspector, and choose Project Attributes from the pop-up menu at the top 
of the panel that appears.


2. Drag the help file from the Workspace Manager to the icon well.
Project Builder adds the file to the project and enters the name of the file in this 
field.
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Managing Files

These sections show you how to create, open, add, and delete files in a project.


“Creating a File” (page 25)


“Opening and Closing a File” (page 28)


“Adding and Removing a File” (page 35)


“Saving a File” (page 40)


Creating a File


You can create a file that’s automatically added to a project, or create a scratch file 
that isn’t.


“Creating a File in the Project” (page 25)


“Creating a File Outside the Project” (page 27)


Creating a File in the Project


This procedure creates a new file and adds it to your project.


1. Choose File>New in Project.


2. Select what type of file to create.
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3. Enter the filename.


1. Choose File>New in Project.
Project Builder displays the New File panel.


2. Select what type of file to create.


Type of File What to Select


Class and header file Select the Class suitcase and the “Create 
header” option. Project Builder will create two 
source file templates and add the class to your 
project’s Class category and the header file to 
the project’s header category. 


Class file only Select the Class suitcase and deselect the 
“Create header” option. Project Builder will 
create a class file template and add it to the 
Class category of the project.


Header file only Select the Header suitcase. Project Builder will 
create a header file template and add it to the 
Header category of the project.
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Use the suitcases and the “Create header” option to choose the type of file (or 
files) you want to create.


3. Enter the filename.
Enter the filename in the Name field. If you’re creating both a class and header 
file, enter the name of the class file. Project Builder will create a header file with 
the same name, substituting .h for .m.


When you click OK, Project Builder creates the specified file (or files) and adds 
them to the project.


Creating a File Outside the Project


1. Choose File>New Untitled.


This procedure creates a new text file that is not part of your project.


1. Choose File>New Untitled.
Project Builder creates a new text file in the temporary directory. 


Another source file (such 
as a file of functions)


Select the Other Source suitcase. Project 
Builder will create an empty text file and add it 
to the Other Sources category of the project.


Text file (such as 
documentation)


Select the Supporting File suitcase. Project 
Builder will create an empty text file and add it 
to the Supporting Files category of the project.


Context-sensitive help file Select the Help suitcase. Project Builder will 
create an empty RTF file and add it to the 
Context Help category of the project.


Type of File What to Select
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Opening and Closing a File


These sections describe all the ways you can open, view, or close a source file in 
Project Builder.


“Switching Between Header and Class Files” (page 28)


“Opening a Text or RTF File from the Project Browser” (page 29)


“Opening a File from the Open Panel” (page 31)


“Opening a File by Typing Its Name” (page 32)


“Viewing Recently Opened Files” (page 33)


“Closing a File” (page 34)


Switching Between Header and Class Files


1. Press the Switch Header/Module .
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This procedure lets you open a file’s corresponding class or header file by simply 
clicking a button.


1. Press the Switch Header/Module .
The Switch Header/Module button is  at the top of the code editor


Project Builder displays the corresponding header or module file. For example, 
it would display Converter.m instead of Converter.h.


Opening a Text or RTF File from the Project Browser


1. Click the file’s name in the project browser.


You can edit text and RTF files in a code editor in Project Builder.


1. Click the file’s name in the project browser.
Project Builder displays the file.
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You can choose where Project Builder opens files: in an editing window or the 
code editor in the Project Builder window. 


Opening Other Files from the Project Browser


1. Double-click the file’s name in the project browser.


If you open a file that’s not a text or RTF file, Project Builder opens it with the 
appropriate application.


1. Double-click the file’s name in the project browser.
Project Builder launches the application, if it isn’t already running, and opens 
the file. 


Categories Files File Contents
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To find the file’s name, click the file’s category in the first browser list and look 
for the name in the second browser list.


Opening a File from the Open Panel


1. Choose File>Open.


2. Select the file from the Open panel


Categories Files
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1. Choose File>Open.
Project Builder displays the Open panel.


2. Select the file from the Open panel
After you click OK, Project Builder displays the file.


You can choose where Project Builder displays files: in a separate editing 
window or the code editor in the Project Builder window. 


Opening a File by Typing Its Name


1. Choose File>Open Quickly.


2. Enter the filename.
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This procedure is useful when you know the file’s exact name and location and you 
can type it quickly.


1. Choose File>Open Quickly. 
Project Builder displays the Open File or Project panel.


The text field contains the pathname for the currently selected project directory. 


2. Enter the filename.
You can enter the filename at the end of that pathname, or edit the pathname.


After you click OK or press Return, Project Builder opens the file.


Viewing Recently Opened Files


1. To display an open file, click its name, or choose Tools>Loaded Files>Next File and 
Tools>Loaded Files>Previous File.
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The loaded files view lets you quickly return to files you’ve already. Sometimes, it 
can be difficult to find a file, especially one that’s buried in a subproject or 
framework. With the loaded files view, you need to find it only once.


1. To display an open file, click its name, or choose Tools>Loaded Files>Next File and 
Tools>Loaded Files>Previous File.
Project Builder displays the file, or it displays the next or previous file in the 
loaded files view


The Next File and Previous File commands work best if you turn off the “Always 
open files in new windows” option in the General display of the Preferences 
panel, so that the files are displayed in the code editor in the Project Builder 
window, one after the other. Otherwise, Project Builder opens a new window for 
each file displayed.


Closing a File


To close a file, choose File>Close. If you’ve edited the file since you’ve last saved it, 
Project Builder asks you if you want to save it now.


Note that if you click the close box, Project Builder hides the file’s window, but 
doesn’t actually close the file. The changes you’ve made stay in memory. Project 
Builder will close the file when you close the project or quit Project Builder.


Loaded Files
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Adding and Removing a File


These procedures describe how to add or remove files from a project.


“Adding a File with the Add Files Command” (page 35)


“Adding Files by Dragging and Dropping” (page 37)


“Removing a File” (page 38)


Adding a File with the Add Files Command


1. Choose Project>Add Files.


2. Choose the type of file to add from the pop-up menu.


3. Specify whether to add a whole folder of files.


4. Select the file from the browser.
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1. Choose Project>Add Files.
A panel appears in which you can locate the file.


2. Choose the type of file to add from the pop-up menu.
The file list displays only those files that match that type.


If you choose Classes, Project Builder adds both the header file and the source 
file for the selected class.


3. Specify whether to add a whole folder of files.
If you chose the category Other Resources or Supporting Files, the Choose 
Folders option is available. To add a file, turn this option off. To add a folder, 
turn this option on. Project Builder treats the folder as if it were a file: within 
Project Builder, you cannot view what it contains. 
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Turning this option on does not add every file in the folder to your project. 
Instead, it adds the folder itself, and you cannot see the files it contains in the 
project browser. 


4. Select the file from the browser.
After you click OK, Project Builder adds the file to the selected category of your 
project.


Adding Files by Dragging and Dropping


1. Select the category to which you’re adding files.


2. Drag the files from the workspace to the suitcase.


1. Select the category to which you’re adding files.
The corresponding suitcase must appear in the upper-right corner of the project 
browser window.
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2. Drag the files from the workspace to the suitcase.
If you drag and drop a class file, Project Builder also copies its corresponding 
header file to the header category.


Removing a File


1. In the project browser, select the file or files to delete.


2. Choose Project>Remove Files.


3. Specify whether to delete the file from the disk as well.


4. If you’re removing class files, specify whether to remove header files as well.


1. In the project browser, select the file or files to delete.


2. Choose Project>Remove Files. 


3. Specify whether to delete the file from the disk as well.
This panel appears, asking whether to permanently delete the files from your 
system as well as remove them from the project:


Suitcase
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■ To leave the files in both the project and the disk, click “Cancel”.


■ To remove the files from the project and leave them on the disk, click “...from 
Project only”. 


■ To remove the files from both the project and the disk—permanently 
deleting them from your system—click “...from Project and Disk”.


4. If you’re removing class files, specify whether to remove header files as well.
If any of the files you’re removing are class files, this panel appears, asking 
whether to remove the corresponding header files as well:


■ To leave the header files in the project, click “Do not remove”.


■ To remove the header files, click “Remove”. If you clicked “...from Project 
and Disk” in the previous panel, Project Builder also permanently deletes the 
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header file from your system.


Saving a File


There are several ways to save files in Project Builder. You can save files by 
command, save copies of files, or have Project Builder automatically save files as 
you work.


“Saving the Current File” (page 40)


“Saving Several Files at Once” (page 40)


“Saving a File Under a New Name” (page 41)


“Saving a Backup of a File” (page 42)


“Automatically Saving Backups of All Modified Files” (page 43)


“Automatically Saving Files When Building” (page 45)


Saving the Current File


1. Choose File>Save, or press Command-S.
Project Builder saves your changes the currently selected file.


Saving Several Files at Once


1. Choose Project>Save Files.


2. Select the files to save, and click Save
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This procedure is useful when you want to save all the modifications you’ve made 
to a project at once, before you build a project or leave your computer for a while.


1. Choose Project>Save Files. 
This panel appears, listing all the modified files: The list includes Interface 
Builder, as well as Project Builder files.


2. Select the files to save, and click Save
When the panel appears, all the files are selected. To deselect a file, 
Command-click it.


If you don’t remember what’s in a file, click its name in the panel. Project Builder 
brings its window to the front of all other windows, although the Save Modified 
Files panel may still cover it. If necessary, move the panel so you can see it.


To save all the selected files, click Save. To save none of the files, click Cancel.


Saving a File Under a New Name


1. Choose File>Save As.


2. Specify the name and location of the file.
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This procedure saves a file to a new name. You continue editing the file under its 
new name. 


This procedure doesn’t replace the renamed file in the project. The file with the 
original name remains. To rename a file, see “Renaming a File” (page 46). 


1. Choose File>Save As.
The Save panel appears.:


2. Specify the name and location of the file.
After you click OK, Project Builder saves the file under the new name.


Saving a Backup of a File


1. Choose File>Save To.


2. Specify the name and location of the file, and click Save.
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This procedure saves a copy of a file with a new name. You continue editing the file 
under its original name.


1. Choose File>Save To.
The Save panel appears.


2. Specify the name and location of the file, and click Save.
After you click OK, Project Builder saves the file under the new name.


Automatically Saving Backups of All Modified Files


1. In the Savings display of the Preferences panel, choose how often to save your 
files.

43







  


C H A P T E R  2


   

Project Builder can automatically save backups of your files at regular intervals, so 
you don’t lose all your changes if Project Builder crashes. 


If you open a file that has already an auto-save version and you edit the file, the new 
auto-save version overwrites the old one. 


1. In the Savings display of the Preferences panel, choose how often to save your 
files.
To display the Savings display of the Preferences panel, choose 
Edit>Preferences, and choose Saving from the pop-up menu at the top of the 
panel.


Under File Auto-Save Options, use the slider to choose how often (in seconds) 
to save your files. The number of seconds appears above the slider. You can 
choose from 5 to 120 (2 minutes).


If you don’t want to save your files automatically, move the slider all the way to 
the right until the world “Disabled” appears above the slider.


At the specified interval, Project Builder saves each modified file under a new 
name, which is the file’s name enclosed in at-signs (@). For example, the 
auto-save version of MyClass.m is @MyClass.m@.
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Automatically Saving Files When Building


1. In the Saving display of the preferences panel, turn on the “Always save files when 
building” option.


Project Builder can automatically save files before you build a project, so you can be 
sure that your project is built with the latest versions.


1. In the Saving display of the preferences panel, turn on the “Always save files when 
building” option.
To display the Savings display of the Preferences panel, choose 
Edit>Preferences, and choose Saving from the pop-up menu at the top of the 
panel.


When you build the project, Project Builder automatically saves every modified 
file, overwriting the old version.


If this option is off, Project Builder displays the Save Modified Files panel when 
you build the project, letting you choose which files to save.
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Renaming a File


1. Choose File>Rename.


2. Enter the file’s new name.


1. Choose File>Rename.
Project Builder displays the Files Attributes display of the Project Inspector, with 
the file’s name selected.


2. Enter the file’s new name.
You can either type over the name or edit it. After you press Return, Project 
Builder renames the file and updates the name in the project browser.
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Finding Information


 


Project Builder can search your code quickly because it keeps your code indexed.


You can control how and when Project Builder indexes your files. 

“Indexing a Project” (page 48)

47


“Indexing Automatically” (page 48)


“Indexing on Another Machine” (page 49)


“Indexing a Project” (page 50)


“Indexing an Individual File” (page 51)


“Purging All Indices” (page 52)


Project Builder lets you search for code, text, and regular expressions in your 
project. You can also replace text and search for documentation. 


“Searching for the Definitions of a Symbol” (page 53)


“Searching for References to a Symbol” (page 57)


“Searching for Text” (page 61)


“Searching for Documentation” (page 70)


“Replacing Text” (page 73)


“Using a Previous Search” (page 77)


“Setting Search Preferences” (page 77)
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Indexing a Project


       

To take full advantage of Project Builder, you must index the source code regularly. 
Indexing keeps track of each symbol in the project, what that symbol defines (such 
as a class or function), where it’s declared, and where it’s used. 


“Indexing Automatically” (page 48)


“Indexing on Another Machine” (page 49)


“Indexing a Project” (page 50)


“Indexing an Individual File” (page 51)


“Purging All Indices” (page 52)


Indexing is performed by a background process called the project server. When you 
request information stored in the index, Project Builder asks the project server for 
that information, then relays it to you. By default, Project Builder starts the project 
server when you first start Project Builder, and indexes a project when it’s opened. 
The project server is kept running and the indices are kept in memory until you log 
out of the system. This means Project Builder will start up more quickly the next 
time you use it.


Indexing Automatically


1. Bring up the Indexing display of the Preferences panel.


2. Turn on the options in the Indexing group.


• ???  INSERT SCREEN SHOT ??? •


If you turn on automatic indexing, your project’s index will be kept up-to-date 
without your needing to do anything. However, letting Project Builder update your 
project automatically can slow down other applications running on the computer. 
Follow these steps to adjust your indexing options for the best performance.


1. Bring up the Indexing display of the Preferences panel.
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Choose Edit > Preferences. The Preferences panel appears. Choose Indexing 
from the pop-up menu at the top of the panel.


 


2. Turn on the options in the Indexing group.


 


The three checkboxes in the Indexing group control when Project Builder 
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indexes a project. Turning on all three options makes sure that your project’s 
index is always up-to-date. Here’s what they do:


■ To index your project when it’s opened, turn on “Index when project is 
opened.”


■ To delete a project’s index when you quit Project Builder, turn on “Invalidate 
when quitting.” If this option is off, the project’s index stays in memory until 
you reboot your computer, and the project is not re-indexed when it’s 
opened, regardless of the setting of the option “Index when project is 
opened.”


■ To update the indexing information for a file when you save that file, turn on 
“Re-index when file is saved.”


Indexing on Another Machine


1. Bring up the Indexing display of the Preferences panel.


2. Enter the computer’s name in the Host field.


• ???  INSERT SCREEN SHOT ??? •


Indexing requires overhead and can slow down other applications running on your 
computer if you’re managing a large project. To have all the benefits of indexing 
without slowing down applications on your computer, you can build and index a 
project on another computer on your network. 


1. Bring up the Indexing display of the Preferences panel.
Choose Edit > Preferences. The Preferences panel appears. Choose Indexing 
from the pop-up menu at the top of the panel.


2. Enter the computer’s name in the Host field.
For the project to index correctly, you must also use the same host to build it. If 
you haven’t already done so, go to the Build Options panel and enter the same 
host in that panel as you did in this panel.
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Indexing a Project


 


1. Choose Tools > Indexer > Index Project.


      

or


1. In the Project Indexer panel, click the Index Project button.


If you’ve turned off automatic project indexing, you can index your project 
manually. See “Indexing Automatically” (page 48), to index your project 
automatically when you open it.


You can index a project manually by choosing one menu command:


1. Choose Tools > Indexer > Index Project.
Project Builder starts up the project server if it isn’t already running and indexes 
all the files in the project.


Or you can do it from the Project Indexer panel:


1. In the Project Indexer panel, click the Index Project button.
To display the Project Indexer panel, choose Tools > Indexer > ShowPanel.


When you click the Index Project button, Project Builder starts up the project 
server if it isn’t already running and indexes all the files in the project.
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Indexing an Individual File


 


1. Choose Tools > Indexer > Index File.
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or


1. In the Project Indexer panel, click the Index File button.


You can index an individual file manually. Doing so is useful after you’ve made a 
lot of changes to a file since you last indexed the project.


See “Indexing Automatically” (page 48) to index a file whenever you save it.


You can index the current file by choosing one menu command:


1. Choose Tools > Indexer > Index File.
Project Builder starts up the project server if it isn’t already running and indexes 
the currently selected file in the project browser. 


Or you can do it from the Project Indexer panel.


1. In the Project Indexer panel, click the Index File button. 
To display the Project Indexer panel, choose Tools > Indexer > Show Panel.


When you click the Index File button, Project Builder starts up the project server 
if it isn’t already running and indexes the currently selected file in the project 
browser. 
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Purging All Indices 


 


1. Choose Tools > Indexer > Purge Indices.


      

or


1. In the Project Indexer panel, click the Purge Indices button.


2. Click Purge.


If you want to purge the indices for all your projects and stop the project server, 
follow these steps. This command might be useful if you’re running low on memory 
or if the project server is slowing down other applications on your computer.


You can do it with a menu command:


1. Choose Tools > Indexer > Purge Indices.
Project Builder purges all the indices currently stored in memory and stops the 
project server. 


Or you can do it from the Project Indexer panel:


1. In the Project Indexer panel, click the Purge Indices button.
To display the Project Indexer panel, choose Tools > Indexer > Show Panel.


When you click the Purge Indices button, Project Builder asks you to confirm 
your action. 
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2. Click Purge.
Project Builder purges all the indices currently stored in memory and stops the 
project server. 


arching for the Definitions of a Symbol


When you search within a project, Project Builder lets you limit your searches so 
you can find just the symbol’s declarations, implementations, and documentation. 
You won’t see any occurrences of the words in comments or strings, or where it’s 
referenced.


“Searching for Definitions by Control–Double-Clicking” (page 53)


“Searching for Definitions With the Project Find Panel” (page 54)


Searching for Definitions by Control–Double-Clicking


1. In a code editor, Control–double-click the symbol’s name.


• ???  Is Command key the same on all platforms ??? •


Use this method to find the definition of a symbol that appears in a code editor. 
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1. In a code editor, Control–double-click the symbol’s name.


 


The Project Find panel appears, listing every location where the symbol is 
defined, implemented, or documented. Also, the symbol you clicked is entered 
in the Find field and Definitions is chosen from the pop-up menu. 


   

To view the source code for the symbol, click its name. To view documentation 
on a symbol, click the book beside its name. If there’s no book beside a symbol’s 
name, there is no documentation on it.


When you perform a search by Control–double-clicking, Project Builder honors the 
option settings in the Project Find panel as they were set before the search. See 
“Setting Options in the Project Find Panel” (page 78), for more information on these 
options.


Searching for Definitions With the Project Find Panel


1. Bring up the Project Find panel.


2. Choose Definitions from the pop-up menu, and set your other options.


3. In the Find field, enter the symbol to search for, and click the Find button.
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Use this method to find the definition of a symbol whose name you know but which 
doesn’t appear in a code editor.


1. Bring up the Project Find panel.
You can either choose Tools>Project Find>Show Panel or click the Project Find 


button  in Project Builder’s main window. The Project Find panel appears.


2. Choose Definitions from the pop-up menu, and set your other options.
The pop-up menu is the top one, to the right of the Find field.


See “Setting Options in the Project Find Panel” (page 78) and “Choosing How to 
Order Search Results” (page 84) for more information on the options you can set.
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3. In the Find field, enter the symbol to search for, and click the Find button.


 


If you want to limit your search to symbols of a particular type, use the 
appropriate syntax from this table:


                 

• ???  Add Java descriptions to table and fix the width. ??? •


To perform a wildcard search, use the * (asterisk) character. Project Builder 
matches any number of characters for the asterisk. For example, “NS*Array” 
finds definitions for NSArray and NSMutableArray. 


Symbol Type Syntax


Class @class


Protocol <protocol>


Instance method –method


Class method +method 


Method in 
particular class


[class method]


Function function()


Macro #macro
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After you click the Find button, Project Builder lists every location where the 
symbol is defined, implemented, or documented. 


To view the source code for a symbol, click its name. To view documentation on 
a symbol, click the book besides its name. If there’s no book beside a symbol’s 
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name, there is no documentation on it.


arching for References to a Symbol


When you search within a project, Project Builder lets you limit your searches so 
you can find those places where a symbol is referenced; such as all the places where 
a function is called or a variable is referenced. You won’t see any occurrences of the 
words in comments or strings, or where it’s defined and implemented.


“Searching for References with the Find References Command” (page 57)


“Searching for References with the Project Find Panel” (page 58)


Searching for References with the Find References 
Command


Use this method to find the references to a symbol that appears in a code editor.


1. In a code editor, place the insertion point in the symbol, and press Command-0 
(Command-Zero). 


• ???  Is Command key the same for all platforms ??? •


You can also choose Tools > Project Find > Find References.
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The Project Find panel appears, listing every location where the symbol is 
referenced. Also, the symbol is entered in the Find field and References is chosen 
in the pop-up menu. 


To go to a location, click it.


When you perform a search this way, Project Builder honors the option settings 
in the Project Find panel as they were set before the search. See “Setting Options 
in the Project Find Panel” (page 78) for more information on these options.


Searching for References with the Project Find Panel


1. Bring up the Project Find panel.


2. Choose References from the pop-up menu, and set your other search options.


3. In the Find field, enter the symbol to search for, and click the Find button.
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Use this method to find the references to a symbol whose name you know but which 
doesn’t appear in a code editor.


1. Bring up the Project Find panel.
You can either choose Tools>Project Find>Show Panel or click the Project Find 


button  in Project Builder’s main window. The Project Find panel appears.


2. Choose References from the pop-up menu, and set your other search options.
The pop-up menu is the top one, to the right of the Find field.
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See “Setting Options in the Project Find Panel” (page 78) and “Choosing How to 
Order Search Results” (page 84) for more information on the other options you 
can set.


 


3. In the Find field, enter the symbol to search for, and click the Find button.


                  

If you want to limit your search to symbols of a particular type, use the 
appropriate syntax from this table:


• ???  Add Java descriptions to table and fix the width. ??? •


To perform a wildcard search, use the * (asterisk) character. Project Builder 
matches any number of characters for the asterisk. For example, “NS*Array” 
finds references to NSArray and NSMutableArray. 


Symbol Type Syntax


Class @class


Protocol <protocol>


Instance method –method


Class method +method 


Method in 
particular class


[class method]


Function function()


Macro #macro
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When you click the Find button, Project Builder lists every location where the 
symbol is referenced. To go to a location, click it.


arching for Text


Project Builder lets you search for text wherever it occurs in a file, whether in a 
comment, string, or in code.


“Searching for Text with the Find Text Command” (page 61)


“Searching Throughout a Project for Text, Batch Mode” (page 62)


“Searching in the Current File for Text, Sequentially” (page 64)


“Searching in the Current File for Text, Incrementally” (page 65)


“Searching for Regular Expressions” (page 68)


Searching for Text with the Find Text Command


• ???  Is Command key the same for all platforms ??? •
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Use this method to find text that appears in a code editor.


 


1. In a code editor, select the text, and press Command-8.


 


Instead of pressing Command-8, you can also choose Tools > Project Find > Find 
Text.


  

The Project Find panel appears, listing every location where the text appears. 
The text is entered in the Find field and Textually is chosen in the pop-up menu. 


To go to a location, click it. 


If one line of code contains two or more occurrences of the Find string, Project 
Builder lists the line multiple times, highlighting different occurrences in each 
and bracketing the lines together. For example, in the above illustration, the last 
two entries are bracketed together since Project Builder found two occurrences 
of “convert” in that line.


When you perform a search this way, Project Builder honors the option settings 
in the Project Find panel as they were set before the search. See “Setting Options 
in the Project Find Panel” (page 78) for more information on these options.


Searching Throughout a Project for Text, Batch Mode


1. Bring up the Project Find panel.
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2. Choose Textually from the pop-up menu, and set your other options.


 


3. In the Find field, enter the text to search for, and click the Find button.
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Use this method to search throughout your project for occurrences of some text.


1. Bring up the Project Find panel.
You can either choose Tools > Project Find > Show Panel or click the Project Find 


button  in Project Builder’s main window. The Project Find panel appears.
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2. Choose Textually from the pop-up menu, and set your other options.


 


The pop-up menu is the top one, to the right of the Find field.


See “Setting Options in the Project Find Panel” (page 78) for more information 
on the options you can set.


    

3. In the Find field, enter the text to search for, and click the Find button.
Note that you can’t use an * (asterisk) as a wildcard character during a textual 
search. Instead, perform a regular expression search, described in “Searching for 
Regular Expressions” (page 68). 


After you click the Find button, Project Builder lists every location where the text 
appears. To go to a location, click it.


If one line of code contains two or more occurrences of the Find string, Project 
Builder lists the line multiple times, highlighting different occurrences in each 
and bracketing the lines together. For example, in the above illustration, the last 
two entries are bracketed together since Project Builder found two occurrences 
of “convert” in that line.


Searching in the Current File for Text, Sequentially


1. Choose Find from the Edit menu.


2. Set your search options.
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3. In the Find field, enter the text to search for, and click the Next or Previous button.
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Use this method if you want to find some text within the file currently selected in 
the project browser. This method does not search within any other file. 


1. Choose Find from the Edit menu.
The Find panel appears.


2. Set your search options.
See “Setting Options in the Find Panel” (page 79) and “Choosing When to Wrap 
Searches” (page 82) for more information on the options you can set.


3. In the Find field, enter the text to search for, and click the Next or Previous button.
Note that you can’t use an * (asterisk) as a wildcard character during a textual 
search. Instead, perform a regular expression search, described in “Searching for 
Regular Expressions” (page 68). 


To find the occurrence that follows the insertion point, click Next. To find the 
occurrence that precedes the insertion point, click Previous.


Searching in the Current File for Text, Incrementally


1. In a code editor, press Control-S or Control-R.


2. Type the text to search for.
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3. Use the buttons as necessary to control the search.


 


Use this method if you want the quickest way to find some text within the file 
currently selected in the project browser. This method is known as incremental 
searching. It does not search within any other file. 


     

See “Setting Incremental Search Options” (page 81) and “Choosing When to Wrap 
Searches” (page 82) for more information on setting options for an incremental 
search.


1. In a code editor, press Control-S or Control-R.
• ???  Is Command key the same for all platforms ??? •


To search forward, press Control-S. To search in reverse, press Control-R. A 
Find field and some buttons appear in a bar at the bottom of the code editor.


2. Type the text to search for.
You don’t need to click in the Find field. Just start typing.
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As you type, Project Builder searches for and selects the next occurrence of what 
you’ve typed so far. 


If it can’t find what you’ve typed, the letters it can’t match appear in red and it 
beeps.
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3. Use the buttons as necessary to control the search.
You can control how Project Builder searches for the text with the buttons beside 
the Find field:


■ To stop searching and return to where you started, click Cancel.


■ To stop searching and stay at the word you located, click OK or press Return.


■ To search for the next or previous occurrence, click Next or Prev.


Searching for Regular Expressions


1. Bring up the Project Find panel.


2. Choose Reg Expr’n from the pop-up menu, and set your other options.


3. In the Find field, enter the regular expression to search for, and click the Find 
button.
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Project Builder lets you search for regular expressions, patterns that match 
particular kinds of characters. For example, “[0-9]+” matches any combination of 
digits.


1. Bring up the Project Find panel.
You can either choose Tools > Project Find > Show Panel or click the Project Find 


button  in Project Builder’s main window. The Project Find panel appears.


2. Choose Reg Expr’n from the pop-up menu, and set your other options.
The pop-up menu is the top one, to the right of the Find field.


See “Setting Options in the Project Find Panel” (page 78) for more information 
on the options you can set.


3. In the Find field, enter the regular expression to search for, and click the Find 
button.
After you click the Find button, Project Builder lists every location that matches 
the expression. To go to a location, click it.


If one line of code contains two or more matches of the regular expression, 
Project Builder lists the line multiple times, highlighting different matches in 
each and bracketing the lines together.
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Searching for Documentation


            

Project Builder lets you search for two types of documentation: documentation on 
frameworks, including the classes in the Yellow Box framework, and 
documentation on command-line tools and standard C functions.


“Searching for Framework Documentation” (page 70)


“Searching for Command-Line Program and C Routine Documentation” (page 72)


Searching for Framework Documentation


1. Perform a definition search on the symbol.


2. Click the book icon of any documentation entry.


Project Builder lets you read documentation on any class in the Apple frameworks 
your project uses, including the Yellow Box framework. The documentation 
appears inside Project Builder, so you can easily browse though the file and follow 
the links until you find the information you need.


1. Perform a definition search on the symbol.
When you search for a symbol’s definition, Project Builder also displays any 
locations in the documentation that describe that symbol. 


There are two ways you can perform a definition search, depending on whether 
or not the symbol appears in the code editor. See the appropriate section for 
more information:


■ “Searching for Definitions by Control–Double-Clicking” (page 53)


■ “Searching for Definitions With the Project Find Panel” (page 54)


2. Click the book icon of any documentation entry.
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Clicking the book displays the documentation in an HTML viewer inside Project 
Builder. 


If you’re viewing documentation on an Apple class (or protocol), scroll to the 
beginning of the file to read an overall description of the class (or protocol) and 
its methods.
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Searching for Command-Line Program and C Routine 


 


Documentation


       

1. Choose Help > System Keyword Lookup.


2. Type the name of the command-line program or standard C library function, and 
click OK.


Rhapsody includes man pages on its command-line programs and standard C 
library routines. You can read these pages within Project Builder, without going to 
the Terminal application and using the man command.


1. Choose Help > System Keyword Lookup.
The Lookup System Keyword panel appears.


2. Type the name of the command-line program or standard C library function, and 
click OK.
Enter the name in the panel’s text field.


When you click OK, Project Builder displays the man page in an editing 
window. 
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If you change your mind, click Cancel. The Lookup System Keyword panel 
disappears without displaying a man page. 


placing Text


You search for and replace text in your files using the Project Find panel and the 
Find panel.


“Replacing Text Throughout Your Project” (page 73)


“Replacing Text in the Current File” (page 75)


Replacing Text Throughout Your Project 


1. Perform a definition, reference, or textual search.


2. In the Replace field, enter the text to substitute for the Find text, and choose the 
entries to replace.


3. Click the Replace button, and click Replace in the alert that appears.
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This method lets you replace text in all the files in your project. 


You can reverse the replacements by choosing Edit > Undo.


1. Perform a definition, reference, or textual search.
For more information, see one of these sections:


■ “Searching for the Definitions of a Symbol” (page 53)


■ “Searching for References to a Symbol” (page 57)


■ “Searching Throughout a Project for Text, Batch Mode” (page 62)


If you perform a definition or reference search, the search results are limited 
to those occurrences in which the symbol is defined or referenced. 
Occurrences of the symbol in comments or strings do not appear.


2. In the Replace field, enter the text to substitute for the Find text, and choose the 
entries to replace.
To examine an entry in the list, click it. Project Builder displays the file and 
selects the Find text.


If you want to replace the text in some but not all of the entries, select the ones 
you want to replace. To select contiguous items, drag across them. To select 
discontiguous items, Shift-click them. To deselect an item, Shift-click it again.


If you want to replace the text in all the entries, don’t select any of them. Project 
Builder will automatically perform the replacement in all of them.
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3. Click the Replace button, and click Replace in the alert that appears.


 


After you click the Replace button, Project Builder displays a panel asking you 
to confirm the replacements. 
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After you click Replace, Project Builder replaces the text in the selected entries.


Note that Project Builder modifies the files, but doesn’t save them. See “Saving 
Several Files at Once” (page 40) to save all the files at once.


Replacing Text in the Current File


1. Choose Edit > Find.


2. In the Find field, enter the text to search for.


3. In the Replace field, enter the text to substitute for what’s in the Find field.


4. Search for an occurrence of the Find text with the Next or Previous button.


5. Choose whether to replace the text and whether to continue.
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This method lets you replace text in the file currently selected in the project browser.


You can reverse the replacements by choosing Edit > Undo.


1. Choose Edit > Find.
The Find panel appears.


2. In the Find field, enter the text to search for.


3. In the Replace field, enter the text to substitute for what’s in the Find field.


4. Search for an occurrence of the Find text with the Next or Previous button.
Project Builder selects the text.


5. Choose whether to replace the text and whether to continue.
Use the buttons in the Find panel to choose how to continue:


■ To replace the text and continue searching, click Replace & Find. 


■ To leave the text unchanged and continue searching, click Next or Previous.


■ To replace the text and stop searching, click Replace.


■ To replace all occurrences of the Find text, click Replace All.


You can choose the range of the Replace All command with the options in the 
Replace All Scope box. To replace each occurrence in the entire file, choose 
Entire File. To replace each occurrence only in the selected text, choose 
Selection. If you want to perform the replacement only within a particular 
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method, for example, select the body of the method, choose Selection, and 
click Replace All.
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sing a Previous Search


To see the results of a previous search without performing that search again, choose 
an item from the Previous pop-up menu in the Project Find panel. 


The list of found items is not updated, so any new occurrences that appeared since 
you last performed the search do not appear in the list, and any old occurrences that 
disappeared are still in the list.


tting Search Preferences


You can customize how Project Builder performs a search by setting various 
search-related options.
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“Setting Options in the Project Find Panel” (page 78)


“Setting Options in the Find Panel” (page 79)


“Setting Incremental Search Options” (page 81)


  

“Choosing When to Wrap Searches” (page 82)


“Choosing How to Order Search Results” (page 84)


Setting Options in the Project Find Panel


You can control how Project Builder searches your project with these three options 
in the Project Find panel: Ignore Case, Whole Words, and Current File. 
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Setting Options in the Find Panel


When you perform a search with the Find panel, you can control how it works with 
these options: Ignore Case and Whole Words.


Option Description


Ignore Case If this option is on, Project Builder overlooks differences be-
tween uppercase and lowercase characters. If this option is 
off, Project Builder matches the Find text only if the case 
matches exactly. For example, say the Find text is 
“MyApp,” If this option is on, it matches “myapp,” 
“MyApp,” and MYAPP.” If this option is off, it matches 
only “MyApp.”


Whole Words If this option is on, Project Builder matches the Find text 
only if it is a separate word in the document. If this option 
is off, Project Builder matches the Find text wherever it oc-
curs in the document. For example, say the Find text is 
“pin.” If this option is on, it matches only “pin.” If this op-
tion is off, it matches “pins,” “pinning,” “opine,” and 
“pin.”


Current File If this option is on, Project Builder searches just the file se-
lected in the project browser. If this option is off, Project 
Builder searches all files in the project.
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Option Description


Ignore Case If this option is on, Project Builder overlooks differences be-
tween uppercase and lowercase, characters. If this option is 
off, Project Builder matches the Find text only if the case 
matches exactly. For example, say the Find text is 
“MyApp,” If this option is on, it matches “myapp,” 
“MyApp,” and MYAPP.” If this option is off, it matches 
only “MyApp.”


Whole Word If this option is on, Project Builder matches the Find text 
only if it is a separate word in the document. If this option 
is off, Project Builder matches the Find text wherever it oc-
curs in the document. For example, say the Find text is 
“pin.” If this option is on, it matches only “pin.” If this op-
tion is off, it matches “pins,” “pinning,” “opine,” and 
“pin.”


Method 
Search


This is an obsolete option and will be removed in a future 
version.
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Setting Incremental Search Options


 


When you perform an incremental search with Control-S or Control-R, you can 
control how it works with these options in the Find display of the Preferences panel: 
“Allow searching for newlines” and “Ignore case.”

81
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To display the Find display of the Preferences panel, chose Edit > Preferences and 
then choose Find from the pop-up menu at the top of the panel that appears.


    

Choosing When to Wrap Searches


When you perform a search in the current file, with either the Find panel, Control-S, 
or Control-R, you can control whether the search wraps with these options in the 
Find display of the Preferences panel: “Enable wrapping” and “Beep when 
wrapping.”


Option Description


Allow searching for 
newlines


If this option is on, pressing Return searches for a 
newline character. If this option is off, pressing Re-
turn is the same as clicking the OK button.


Ignore Case If this option is on, Project Builder overlooks differ-
ences between uppercase and lowercase, characters. 
If this option is off, Project Builder matches the Find 
text only if the case matches exactly. For example, 
say the Find text is “MyApp,” If this option is on, it 
matches “myapp,” “MyApp,” and MYAPP.” If this 
option is off, it matches only “MyApp.”
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To display the Find display of the Preferences panel, chose Edit > Preferences and 
then choose Find from the pop-up menu at the top of the panel that appears.


    

Choosing How to Order Search Results


When you perform a search with the Project Find panel, you can control how it 
orders the search results with a setting in the Find display of the Preferences panel. 


Option Description


Enable wrapping If this option is on, Project Builder starts search-
ing from the beginning of the file when the search 
reaches the end of the file. If this option is off, 
Project Builder stops searching when it reaches 
the end of the file.


Beep when wrapping If this option is on, Project Builder beeps when it 
reaches the end of the file and starts searching 
from the beginning. This option has no effect if 
the “Enable wrapping” option is off.
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To display the Find display of the Preferences panel, chose Edit>Preferences and 
then choose Find from the pop-up menu at the top of the panel that appears.


If the “Order results by type (vs. location)” option is on, the results are sorted by 
symbol type; for example, all the functions are together, all the methods are 
together, and so on. If that option is off, the results are sorted by which file they’re 
in.







  


C H A P T E R  


 


Localizing


 


L


           

87


ocalizing—Summary of Steps


This section ives an overview of how to localize an application for multiple 
languages and locations.


 Localizing an Application—Summary of Steps


1. Write and debug your program for one language.


2. In Project Builder, add a new language to the project.


3. In Interface BuilderProject Builder, localize the nib files for that language.


4. Repeat steps 2 and 3 for each additional lanuage.


5. Build the project.


Here are the steps for localizing an application:


1. Write and debug your program for one language. 
Localizing an application into more languages should be the last step, 
after it's completely written and debugged for one language.


As you write the application, keep these pointers in mind:


■ If you want to localize a file later, you must mark it localizable. For 
more information, see “Making a File Localizable” (page 91).


■ Use localized resources whenever possible. 
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■


 


Instead of using hard-coded strings in your code, use a .strings file, 
which can be localized. 


 


■


 


Leave enough room in your interface for languages which need 
longer strings.


         


Lo


      

2. In Project Builder, add a new language to the project. 
See “Adding A New Language to a Project” (page 88).


3. In Interface BuilderProject Builder, localize the nib files for that 
language. 
See the Interface Builder documentation.


4. Repeat steps 2 and 3 for each additional lanuage. 
As you edit, you may need to switch between languages. See 


“Changing the Project’s Current Language” (page 90).

5. Build the project. 
Project Builder automatically copies the localized files into the 
application wrapper. 


calizing—The Steps


The following sections give the details for localizing an application.


Adding A New Language to a Project


1. Create and fill directories named language.lproj for the project and its subprojects.


2. In the Project Attributes display of the Project Inspector, enter the name of the 
language in the Language field.


After you’ve completely written and debugged an application in one language, you 
can localize it for other languages.


1. Create and fill directories named language.lproj for the project and its 
subprojects.
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Create the new directory in the directory that contains the PB.project 
file for the project. Name it language.lproj, where language is the 
language’s English name. Place all the files for the new language 
inside it. 
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You can also create the new directory by duplicating an exisiting .lproj 
directory and renaming it.


If your project contains subprojects, you must repeat this step for each 
of the subprojects.


If you add a file to an .lproj directory later on, you must add localized 
versions of that file to the other .lproj directories in the project.


2. In the Project Attributes display of the Project Inspector, enter the name 
of the language in the Language field.
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To display the Project Attributes display of the Project Inspector, 
choose Tools>Inspector , and choose Project Attributes from the 
pop-up menu at the top of the panel that appears.


In the Language field, enter the English name for the language. It must 
be the same as the name of the new directory without the .lproj 
extension.


Now when you open the nib files for this project, you’ll open the files 
in the new .lproj directory.


Changing the Project’s Current Language


1. In the Project Attributes display of the Project Inspector, enter the name of the 
language in the Language field.
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While you’re localizing an application for different languages. you may need to 
switch between languages.


1. In the Project Attributes display of the Project Inspector, enter the name 
of the language in the Language field.
To display the Project Attributes display of the Project Inspector, 
choose Tools>Inspector, and choose Project Attributes from the 
pop-up menu at the top of the panel that appears.


In the Language field, enter the English name for the language. 


Now when you view the interface files for your project, only those 
files for this language appear. And when you turn on the Localizable 
Resource option for a file in the File Attributes display, Project Builder 
places the file in that .lproj subdirectory


Making a File Localizable


1. Select the file.


2. In the File Attributes display of the Project Inspector, turn on the Localizable 
Resource option.
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If you add a file to a project and later decide that you want to localize it for different 
languages, use this procedure.


1. Select the file.


2. In the File Attributes display of the Project Inspector, turn on the 
Localizable Resource option.
To display the File Attributes display of the Project Inspector, choose 
Tools>Inspector, and choose File Attributes from the pop-up menu at 
the top of the panel that appears.


Project Builder automatically places the file in the .lproj directory for 
the project’s current language.
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