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DEVELOPING JAVA
APPLICATIONS: A TUTORIAL

Sections

Building a Simple Application

Ereating a Custom View Clasg

Related Concepts

Rhapsody'’s Java Feature (Premier)

The Java Bridge
Developing 100% Pure Java Applications

With the Premier release you can write Rhapsody programs in Java™ as
well as in Objective-C, C++, C, and PostScript. You can build a Yellow Box
application that is written exclusively in Java or that is a mix of Java and
another supported language.

This tutorial walks through the basic steps for developing a Java Yellow
Box application with the features available in the second Developer
Release. The feature set will be extended and refined in future releases,
and the procedure will thus be even easier.

Fast Track to Java Development:This section summarizes the different
steps in Java development for programmers with experience in
developing Objective-C Yellow Box applications
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What You'll Learn in This Tutorial

In this tutorial you will build a simple application that converts
temperature values between Celsius and Fahrenheit. The application will
display a different image depending on the temperature range. Here’s
what the finished application looks like:

Temperature Converter =—"—H

Fahrenheit Celsius

100 |3F"

The tutorial has two parts:

Building a simple application. Explains how to create a project and a
graphical user interface, define a custom controller class, and connect
an instance of that class to other objects in the application. It also
shows how you must change the source code files generated by
Inteface Builder to be valid Java files.

Creating a custom view class. Shows how to create a custom view
object using Interface Builder and Project Builder. (The procedure
varies from that for controller classes.)
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Fast Track to Java Development

If you are an Objective-C programmer who is familiar with the Rhapsody
development enviroment and the Yellow Box APIs, you’re probably
interested only in the differences in the development procedure between
Obijective-C and Java:

Controller classes must inherit from java.lang.Object. You can specify
this relationship in Interface Builder’s Classes display when you
define the class.

In Interface Builder, when you create a source-code file for a Java
controller class (by choosing Classes>Create Files), Java code is
generated. However, since Java has no notion of dynamically typed
objects (id), it substitutes java.lang.Object as the type of outlets and
senders of action messages. You must specify the correct class typesin
place of Object. In other words,

Obj ect nyText Fi el d;
public void doThi s(Obj ect sender)

must be translated to this:

NSText Fi el d nyText Fi el d;
public void doThi s(NSButton sender)

If you don’t specify the correct class type, you must cast to that type
in the code.

The classes that Interface Builder presents in its Classes display
represent, in most cases, both Objective-C and Java Yellow Box
classes. And the process for defining a class and connecting its outlets
is the same for both Yellow Box language versions. However, before
you create the “skeletal” source files to be added to Project Builder,
select the class and then select the language in the inspector’s
Attributes display, Interface Builder then generates the source file in
the requested language.
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BUILDING A SIMPLE APPLICATION
1

Creating a Project
Creating the Interface

Defining the Controller Class

Connecting Objects
Implementing the Controller Class

Building and Running the Application

The following pages guide you through the creation of a very simple
Rhapsody application and in the process teach you the steps essential to
building a Yellow Box application written in Java. By the end of this
tutorial you will have created an application called Temperature
Converter that looks like this:

Temperature Converter =——— B

Fahrenheit Celsius

100 |3F"
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This application does exactly what its name suggests, converting Celsius
values to Fahrenheit, and vice versa. The user just types a value in one of
the text fields and presses the Return key. The converted value is shown
in the other field.

Although this application is simple, the experience of putting it together
will clarify a few central techniques and paradigms in Yellow Box Java
development, among them:

Creating graphical user interfaces with Interface Builder
Defining custom Java controller classes with Interface Builder

Connecting an instance of the controller class with other objects in the
application

Generating source files from Interface Builder definitions and
modifying those files to be suitable for Java compilation

Building the project, after writing the necessary Java code

Important

In future releases you won’t have to prepare the
generated source files for Java, as you now must
do in the Developer Release. Interface Builder
will automatically create proper Java files from
the definitions of subclasses. Thus some of the
details in this tutorial are applicable only to the
development environment in the Developer
Release.
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CREATING A PROJECT

Launch Project Builder

Choose the New Command

Name the Project

The procedure for creating an Objective-C project is the same as the procedure for
creating a Java project.

Launch Project Builder

Project Builder is the application typically used for creating and managing
development projects in Rhapsody. To launch Project Builder:

1. Find ProjectBuilder.app in /System/Developer/Applications and select it.

2. Double-click the icon in the File Viewer.

Choose the New Command

When Project Builder is launched, only its menus appear. To create a project, choose
New from the Project menu. This action causes the New Project panel to appear.
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Name the Project

All projects must have a name, a location in the file system, and a type designation.
The New Project panel allows you to set all these things.
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1. Using the file-system browser, navigate to the directory where you want your
project to be.

One convention, as shown in the example, is to have a subdirectory in your
home directory named Projects.

2. Type the name of the project in the Name field. For the current project, type the
name “TemperatureConverter.”

The name of the project becomes, by default, the name of the project directory
and the resulting program.

3. Make sure the project type, as displayed in the pop-up list, is Application.
4. Click OK.

When you click OK, Project Builder creates and displays a project window. After it
opens the window, it indexes the project.

Related Concepts: A Project Window, Project Indexing

You might want to look in the project directory to see what kind of files it now
contains. Among the project files are:

Makefiles
Three files contain build information related to the project. The
Makefile file is maintained by Project Builder itself using the choices
you make in inspector panels and elsewhere. Do not modify this file.
You can however, customize the Makefile.preamble and
Makefile.postamble files. (See <<x-ref>> for details.)
Templates
Templates for both Objective-C and Java souce code files.
English.lproj/
A directory containing resources localized to your preferred language.
In this directory are nib files automatically created for the project.
TemperatureConverter_main.m
A file, generated for each project, that contains the entry-point code for
the application in main().
You’ll also see a file named PB.project. This file contains information that defines
the project (don’t modify this file either). You can open the project for subsequent
sessions by double-clicking this file.

Related Concepts: What’s a Nib File?
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CREATING THE INTERFACE

Open the Main Nib File

Resize the Window

Rename the Window

Put Text Fields in the Window

Set Attributes of the Text Fields
Add Labels for the Text Fields

The procedure for creating a graphical user interface in an Objective-C project is the
same as the procedure for creating a graphical user interface in a Java project.

Open the Main Nib File

Each application project, when first created, includes a blank nib file called the
“main nib file.” This nib file contains the application menu and perhaps one or more
windows. Applications automatically load the main nib file when they are
launched.

1. Locate the file TemperatureConverter.nib in the Interfaces category in the
project browser.

The main nib file has the same name as the project. A default main nib file is also
provided for other platforms (in this case, Windows NT).

2. Double-click the suitcase icon in the upper-right corner of the project window.

Related Concepts: A Project Window, The Windows of Interface Builder,
What’s a Nib File?

11
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Resize the Window

The window provided for you in the main nib file is too large. To resize a window,
drag either lower corner of the window in any direction (up, down, diagonal).

[ ="——a=—"s My Window

| =)
N

You can resize a window to exact dimensions by entering pixel values in the Size
display of Interface Builder’s Inspector (see Place and Resize the CustomView
Object of the second part of the tutorial for an example of how this is done).

Rename the Window

12

Windows usually carry distinctive titles in, of course, their title bars. In the Yellow
Box of Rhapsody, each window in a screen is based on an instance of NSWindow.
The title of awindow is an attribute of this object. Interface Builder allows you to set



CHAPTER 1

the attributes of NSWindows and many other objects in its Inspector.
To set the title of the TemperatureConverter window:

1. Select the window by clicking it.
2. Choose Inspector from Interface Builder’s Tools menu.

3. Inthe Attributes display of the Inspector, enter “Temperature Converter” in the
Title field, replacing “My Window.”

If the Attributes display is not shown, select it from the pop-up list.

13
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i Window Inspector Hj =

Aftributes B

Title: |Temperature Converer

Backing Controls
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[+ Cne shot

] Dynamic depth limit
] Wants to be caolor

4. Uncheck the Close and Resize checkboxes. These window attributes don’t make
sense with an application as simple as this.
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Put Text Fields in the Window

Interface Builder’s Palette window has several palettes full of Application Kit
objects. The Views palette holds many of the smaller objects, among which is the
text-field object. You now will add two text fields to the TemperatureConverter
interface:

1. Select the Views palette.
This is what the button for the Views palette looks like this when it’s selected:

2. Drag a text field object from the palette toward the Temperature Converter
window.

3. Drop the object (by releasing the mouse button) in the window at one of the
locations shown below.

Once you drop the object, you can reposition it in the window by dragging it.
4. Delete the string “Text” from the object.
To delete the string, double-click to highlight it, then press the Delete key.

15
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[1 =——— Temperature Converier

|

Repeat steps 2 through 4 for the other text field.

If you need to delete an object in the interface, just select it and press the Delete key.

Set Attributes of the Text Fields

Earlier you set an attribute of the TemperatureConverter window (its title). Now
you need to set an attribute of each of the text fields. All objects on Interface
Builder’s palettes have attributes that you can set through the Inspector.

Select a text field.
Choose Inspector from the Tools menu.

Choose Attributes from the Inspector’s pop-up list, if it is not already selected.

A w NP

Check the radio button labeled “Only on Enter” in the Send Action group.

Repeat this sequence for the other text field.
Important

You do not have to set the “Send action on Enter”
attribute. If what you want is the the default behavior for

16



CHAPTER 1

text fields—the field sends its action message to its target
whenever the insertion point leaves it—then leave the
checkbox unchecked. When the “Send action on Enter”
attribute is checked, the text field sends its action message
only when the user presses the Enter or Return key while
the insertion point is in the field.

Add Labels for the Text Fields

Text fields without labels would be confusing to users, so solve that problem by
labeling each field.

1. Drag the "Message Text" object from the Views palette and drop it so it’s just
above the left text field.

2. Double-click the label so it’s highlighted, then type “Fahrenheit”.

3. Change the font size of the label (it’s too large):

1.
2.
3.

Double-click the label to select it.
Choose Format>Font>Font Panel.

Select “From user’s application font” from the Use Family and Typeface pop-up
list.

In the Font panel, select 16 under Size and click OK.

17
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| Font Panel HE
Helvetica Medium 16.0 pt.

Family Typeface | Size
Couriet Medium | 16
Helvetica Chligue 5
Qihlifs Bald 3
Symbol Bold Ohligue o B
Times

11
12 =
14
0 ||
15 |=|
24 |-

Use Family and Typeface

[ From user’s message font | = I

| [ & Fonts 3| Rever ]H set ||

Repeat the steps for the other label (“Celsius”).
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DEFINING THE CONTROLLER CLASS
1

Identify the Class and Its Superclass

Specify the Outlets of the Class

Specify the Action of the Class

Interface Builder not only lets you construct the user interface of an application
from real objects stored on palettes, but lets you partially define a class in terms of
its name, its superclass, its outlets, and its actions.

Identify the Class and Its Superclass

You define a custom class using the Classes menu and the Classes display of the
nib file window.

1. Click the Classes tab of the TemperatureConverter nib file window.
2. Highlight java.lang.0bject in the list of classes.
3. Choose Subclass from the Classes menu.

“MyObject” appears in an editable field below java.lang.0bject.

4. Type “TempController” in place of “MyObject” and press Return.

19
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Specify the Outlets of the Class

20

An outlet is a reference one object holds to another object so that it can easily send
that object messages; it is an instance variable of type id or 1BOutlet. The
TempController has two outlets, one to each of the text fields in the user interface.

1. Click the small electric-outlet icon to the right of TempController in the Classes
display.

This action expands the area under TempController to include “Outlets” and
“Actions.”

2. Select “Outlets.”

3. Choose Add Outlet from the Classes menu.
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You can press the Return key instead of choosing the menu command.
4. Type “celsius” in place of “myOQutlet.”

5. Repeat steps 2 through 4, this time naming the outlet “fahrenheit”.

o TempController
Chitiars
celsius
fahirenheit
Acticns

To collapse the TempController item, click any other class.

Specify the Action of the Class

An action refers to a method invoked in a target object when a user event occurs,
such a the click of a button or the movement of a slider. We want a method in
TempController to be invoked whenever the user presses the Return key in a text
field.

1. Click the small target icon to the right of TempController in the Classes display.

21
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This action expands the area under TempController to include “Outlets” and
“Actions.”

2. Select “Actions.”
3. Choose Add Action from the Classes menu.
You can press the Return key instead of choosing the menu command.

4. Type “convert” in place of “myAction” (parentheses are automatically
appended to the method name).

See the illustration above for an example of what things look like when you
complete this task.

Related Concepts: The Target/Action Paradigm
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CONNECTING OBJECTS

Create an Instance of the Controller Class

Connect the Controller to Its Outlets

Connect the Action of the Controller

Connect the Responders

Test the User Interface

Interface Builder enables you to connect a custom object to its outlets and to the
objects in the user interface that invoke action methods of the custom object. This
connection information is stored in the nib file along with the user interface objects,
class definitions, and nib resources.

Create an Instance of the Controller Class

Before you can connect a custom object to objects in the user interface, you must
create an instance of the object. (This is not a real instance, but a “proxy” instance
representing the connections to the object. The real instance is created when the nib
file is loaded.)

1. Select the TempController class in the Classes display of the nib file window.
2. Choose Instantiate from the Classes menu.

The nib file window automatically changes to the Instances display, and an
instance of the TempController class (depicted as a cube) appears in the display.

23



CHAPTER 1

Connect the Controller to Its Outlets

Follow this Interface Builder procedure to connect the TempController custom
object to its outlets:

1. Control-drag from the cube representing the custom object to the Fahrenheit text
field (the editable field, not the label). A thick black line follows the cursor
while you drag.

“Control-drag” means to hold down the Control key while dragging the mouse
(moving it with the mouse button pressed).

24
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L] Temperature Converter

Fahrenheit Celsius
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2. When a box encloses the Fahrenheit field, release the mouse button.

3. Interface Builder shows the Connections display of its Inspector. The left col-

umn of this display lists the outlets defined by TempController.

25
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L] Custom Object Inspector HH
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4. Select the fahrenheit outlet.
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5. Click the Connect button.
Repeat steps 1 through 5 for the celsius outlet.

Connect the Action of the Controller

Follow this Interface Builder procedure to connect the action method defined by
TempController to the objects that might invoke that method:

1. Control-drag from the the Fahrenheit field (the editable field, not the label) to
the cube representing the custom object. A thick black line follows the cursor
while you drag.

27
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2. When a box encloses the cube, release the mouse button.

Interface Builder shows the Connections display of its Inspector. The right col-
umn of this display lists the action defined by TempController.
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3. Select the convert () action.
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4. Click the Connect button.
Repeat steps 1 through 4 for the Celsius field.

Connect the Responders

30

As a convenience to users, you want the insertion point to be in a certain field after
the application is launched. For the same reason (convenience), you want users to
be able to switch between the fields without having to use the mouse—they should

be able to tab between the fields. You can specify this behavior entirely in Interface
Builder:

1. Click the Instances tab of the nib file window.

2. Control-drag a connection line from the window icon to the Fahrenheit field.
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Temperature Converter

Fahrenheit Celsius
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3. Inthe Connections display of the inspector, select initialFirstResponder.

4. Click the Connect button of the inspector.
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Control-drag a connection line from the Fahrenheit field to the Celsius field.
In the Connections display, select nextkeyView and click Connect.

Control-drag a connection line from the Celsius field to the Fahrenheit field.

© N o O

In the Connections display, select nextkeyView and click Connect.

What have you just done? You’ve specified the sequence of responder objects in the
user interface that are to receive the focus of keyboard events when users press the
Tab key.

Related Concept: The View Hierarchy and the First Responder.

Test the User Interface

32

If you feel so inclined, you could test the user interface you’ve constructed with
Interface Builder. Save the nib file and choose Test Interface from the Document
menu. Interface Builder goes into test mode and the window and text fields you’ve
just created behave as they would in the final application—except, of course, there
is yet no custom behavior.

Notice that the insertion point is initially in the Celsius field. Press the Tab key;
note how the insertion point jumps between the fields. Type something into one of
the fields, then select it and choose Cut from the Edit menu. Click in the other text
field and choose Paste from the Edit menu. These are but a couple of examples of
features you get in any application with little or no work on your part.
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IMPLEMENTING THE CONTROLLER
CLASS

Generate the Source Code Files

Modify the Source Code Files

Implement the convert Method

Write a Patch for Windows Applications

You’re now ready to generate source-code template files from the nib file you’'ve
created with Interface Builder. After that, you’ll work solely with the other major
development application, Project Builder. Because the development tools are at an
early stage of Java integration, you must modify the generated files before you can
begin writing code.

Generate the Source Code Files

To generate the source-code templates files for TempController, in Interface
Builder:

Click the Classes tab in the nib file window.
Select the TempController class.
Choose Create Files from the Classes menu.

Respond to the query “Create TempController.java?” by clicking Yes.

o M w N

Respond to the query “Insert file in project?” by clicking Yes.

33
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Interface Builder creates a TempController.java file and puts it in the Classes
category of Project Builder. You can now quit Interface Builder (or, better still, hide
it) and click in Project Builder’s project window to bring it to the front.

Modify the Source Code Files

34

In Project Builder, perform the following steps to modify the generated files:

1. Click the Classes category in the left column of the project browser.

Related topic: A Project Window.

2. Click TempController.java in the second column.
The following code is displayed in the code editor:

i nport com appl e. yel | ow. application.*;
public class TenpController {

bj ect cel si us;
bj ect fahrenheit;

public void convert (Object sender){

}
}

3. Modify the above code so that it looks like this:

i mport com appl e. yel | ow. application. *;
public class TenmpController {

NSText Fi el d cel si us;
NSText Fi el d fahrenheit;

public void convert (NSText Field sender) {

}



CHAPTER 1

Why is this modification necessary? Java is a strongly typed language and has no
equivalent for the Objective-C dynamic object type id. When Interface Builder
generates source-code files for Objective-C classes, it gives id as the type of outlets
and as the type of the object sending action messages. This id is essential to the
method signature for outlets and actions. However, when it generates Java
source-code files, it substitutes the static Java type object for id.

Implement the convert Method

Finally implement the convert method in Java, as shown here:
i nport com appl e. yel | ow. application.*;
public class TenmpController {

NSText Fi el d cel si us;
NSText Fi el d fahrenheit;

public void convert (NSText Fi el d sender) {
if (sender == celsius) {
int f = (int)((9.0/5.0 * celsius.intValue()) + 32);
fahrenheit.setlntValue(f);
} else if (sender == fahrenheit) {
int ¢ = (int)((fahrenheit.intValue()-32) * 5.0/9.0);
cel sius. setlntValue(c);

}
You can freely intermix Yellow Box and native Java objects in the code. And you
can use any Java language element, such as the try/catch exception handler.

35
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Write a Patch for Windows Applications

If you’re writing the application to run on Yellow Box for Windows, you must
write some code that works around a problem with the Java virtual machine (VM)
on Windows. Because the way the VM implements security-manager features, it
will otherwise not allow any native method to be loaded through a class loader.

The best place to put the code shown below is in:

= Astatic initializer in the principal class
= Your application delegate’s applicationDidFinishLaunching method

The code to add is the following:

try |
com.apple.security.NullSecurityManager.installSystemSecurityManager();
} catch (Exception e) {
// Can’t install it
}
If the exception is raised, the “null” security manager cannot be installed and thus
native code might not be invoked properly.

36
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BUILDING AND RUNNING THE
APPLICATION

Build the Project

Launch and Test the Project

You’ve completed the work required from you for the Temperature Converter
project. Now it’s Project Builder’s turn to work.

Build the Project

To build the project:

1. Click the Build icon in the project window to display the Build panel.

N

=

2. Click the same icon in the Build panel.

You can also press Command-Shift-B to start building directly, bypassing step 1.

Project Builder begins compiling and linking the project code. It reports progress in
the Build panel. If there are errors, Project Builder lists them in the upper part of

37
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the display area. Click a line reporting an error to have Project Builder scroll to the
site of the error in the code editor.

Related concept: The Build Panel.

The build target for Application projects is, by default, “app” (for application). By
clicking the checkmark button on the Build panel, you can bring up the Build
Options panel, where you can set the target to “debug” (which creates an
executable with extra symbols for debugging) or set other per-build parameters.

Launch and Test the Project

38

Of course, once the application has been built, you’ll want to launch the
application to see if it works as planned. You have at least two ways of doing this:

= Locate the file TemperatureConverter.app in the project directory. Double-click
this file to launch the application.

= Click the Launch/Debug icon on the project window

Then click the Launch icon on the Launch/Debug panel.
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CREATING A CUsTOM VIEW

Defining the Subclass
Connecting the View Object

Implementing the View Subclass

Completing the Application

This section of the tutorial describes the basic steps for creating a custom view and,
more specifically, shows how to create a sublcass of an Application Kit class that
itself inherits from NSView. In this section, you will add a custom “image view” to
the user interface you created in the first part of this tutorial. This custom object will
respond to messages from the controller object, TempController, and change its
image depending on the temperature entered. Here’s what the final
TemperatureConverter application will look like:

Temperature Converter =——H

Fahrenheit Celsius

100 |3F"
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The behavior that your custom view object adds to its superclass, NSImageView, is
trivial. You could just as well accomplish the same behavior by sending messages
to an “off-the-shelf” instance of NSImageView. But the subclass illustrates the basic
procedure for making subclasses of Yellow Box classes that don’t inherit from
java.lang.Object.

Creating a Subclass of NSView summarizes the procedure and provides example
code for creating a subclass of NSView whose instances can draw themselves. This
example subclass can replace the one you will create in this section, because it draws
graphical shapes instead of displaying images when the temperature changes to
another range.
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DEFINING THE SUBCLASS

Place and Resize the CustomView Object

Specify the Subclass

Assign the Class to the CustomView

Place and Resize the CustomView Object

The CustomView object on Interface Builder’s Views palette represents an instance
of any custom subclass of NSView or of any Application Kit class that inherits from
NSView. The CustomView object lets you specify the basic attributes of all view
objects: their location in a window and their size.

1. Drag the CustomView object from the Views palette and drop it in the window.

Center it in the window beneath the text fields.
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Fahrenheit Celsius

— —

2. Resize the CustomView using the Size inspector.

Choose Inspector from the Tools menu, select the Size display, and enter 64 in
both the width (w) and height (h) fields.
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Specify the Subclass

As you did earlier with the controller object TempController, you must provide the
name and superclass of your custom class. But now, instead of inheriting from

java.lang.Obiject, your class inherits from an Application Kit class.

1. In the Classes display of the nib file window, select the NSImageView class.

If a class in the display has a filled-in circle next to it, you can click the circle to

reveal the subclasses of that class. The path you want to follow is this:
NSObject, NSResponder, NSView, NSControl, NSImageView.

[£] = ] Temperature Converter.nib — ...English.proj = 15
f Instances Y Classes Y Sounds Y Images ‘t‘
Makdenultem
o MNSResponder 1@
ME&pplication 2@ 0@ |
o MSWiew c@ =@ |=
MSE - 2@ 2@ [
o MSControl z@ 7@
MSBrowser 2@ 10
@ MSButton :@ =&
MSColordell @ =@ (.
O NSlmageliew :@ 7@ |+
| e

2. Choose Subclass from the Classes menu.

46




CHAPTER 2

3. Name the class TemplmageView.

There is no need to specify any outlets or actions for this class.

Important

Currently, Inteface Builder lists the Objective-C set of
Yellow Box classes in its Classes display. This set does not
map exactly to the Java set. The release notes for the
Yellow Box Java APIs (JavaAPl.html in
/System/Documentation/Developer/YellowBox/
ReleaseNotes describes which Objective-C Foundation
and Application Kit classes and protocols were exposed as
Java classes and interfaces, and which Java classes are
new. For those Objective-C classes that were not exposed,
it indicates the JDK counterparts that you can use instead.

Assign the Class to the CustomView

Unlike custom controller classes, where you use the Classes>Instantiate command
to make an instance, you make an instance of a custom view in Interface Builder by
assigning the class to the CustomView object.

1. Select the CustomView object.
2. Select the Custom Class display of the inspector.
3. Select the TemplmageView class in the list provided by that display.
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=——— Custom View Inspector
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Notice how the title of the custom view object changes to “TemplmageView.”
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CONNECTING THE VIEW OBIJECT

Specify a Controller Outlet

Connect the Instances

The TemplmageView itself has no outlets or actions, but the controller object
TempController needs to communicate with it to tell it when the temperature value
changes. One additional outlet in TempController is needed for this purpose.

Specify a Controller Outlet

You can always add an action or outlet to an existing custom class. Just make sure
the header and implementation files of the class (if created) reflect the new outlet or
action.

1. Select the TempController class in the Classes display of the nib file window.
2. Click the electrical-outlet icon next to the class.

3. Choose Add Outlet from the Classes menu (or just press Return).

4. Type the name of the outlet, “templmage”.

Before you move on the next step, be sure to collapse the listing of outlets and
actions by clicking another class.
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Connect the Instances

You’ve already created an instance of TempController; all you need to do now is
connect it to the TemplmageView instance through the tempImage outlet.

1. Click the nib file window and the application window to bring them both to the
front of the screen.

2. Drag a connection from the TempController instance in the Instances display to
the custom view object (TemplmageView) in the application window.
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3. Select the tempImage outlet in the Connections view of the inspector and click

Connect.
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IMPLEMENTING THE VIEW SUBCLASS
1

Generate the .java File

Implement the Constructor

Implement the Image-Setting Method

Call the Image-Setting Method

Generate the .java File

52

The classes under NSObject in the Classes display of the nib file window represent,
in most cases, both Java and Objective-C versions of the same class. When you

create source code files from your nib-file definitions, you must specify which
language you want.

1. Select TemplmageView in the Classes display of the nib file window.
2. Select the Attributes display of the inspector.
3. Click the Java radio button.
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53



CHAPTER 2

Implement the Constructor

54

The constructor for TemplmageView loads image files from the application’s
resources, converts them to NSImage objects, and assigns these to instance
variables. (You’ll add these images to the project later in this tutorial.) It also sets
certain inherited attributes of the image view. The following procedure approaches
the implementation of this constructor in three steps.

1. Add the instance variables for the three NSImages as shown here:

/* TempImageView */

import com.apple.yellow.application.*;
import com.apple.yellow.foundation.*;

public class TempImageView extends NSImageView {
protected NSImage coldImage; // add this
protected NSImage moderatelmage; // add this
protected NSImage hotlImage; // add this

2. Load the images, create NSImages, and assign them to instance variables.

public TempImageView(NSRect frame) {
// load images
super(frame);
coldImage = new NSImage("Cold.tiff", true);
if (coldImage == null) {
System.err.printin("Image Cold.tiff not found.");
}
moderatelmage = new NSImage("Moderate.tiff", true);
if (moderatelmage == null) {
System.err.printin("Image Moderate.tiff not found.");
}
String h = NSBundle.mainBundle().pathForResource("Hot", "tiff");
if (h !=null) {
hotImage = new NSImage(h, true);
b oelse |
System.err.printin("Image Hot.tiff not found.");
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There are a few things to observe about the above excerpt of code:

o TemplmageView’s constructor is based on NSImageView’s
NSImageView(NSRect) method, so the first thing done is a call to super’s
constructor.

o It uses NSImage’s constructor NSImage(String, boolean) to locate the
specified image resource in the application bundle and create an NSImage
with it.

o For the third image (just to show how it can be done differently) NSBundle’s
pathForResource(String, String) method is called to locate the image and
return a path to it within the application bundle. This path is used in the
NSImage(String, boolean) constructor.

o The error handling in this constructor is rudimentary. In a real application,
you would probably want to implement something more useful.

3. Set attributes of the image view:

setEditable(false);

setImage(moderatelmage);

setImageAlignment (NSImageCell.ImageAlignCenter);
setImageFrameStyle(NSImageCell.ImageFrameNone);
setImageScaling(NSImageCell.ScaleProportionally);

The foregoing procedure might lead you to wonder how you might learn more
about the methods of a Yellow Box class, especially their arguments and return
types. The current versions of Rhapsody and Yellow Box for Windows provide a
tool to help you, Java Browse, and also include a “skeletal”” version of the Java
reference documentation in which each method has an HTML link to its Objective-C
counterpart.

Implement the Image-Setting Method

TemplmageView has one public method that TempController calls whenever the
user enters a new temperature value: the tempdidChange method.

public void tempDidChange(int fahreheit) {
if (degree < 45) {
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setImage(coldImage);
} else if (degree > 75) {
setImage(hotImage);
} else setImage(moderatelmage);
}
These ranges are completely arbitrary, but could be influenced by a California
climate. If you have lower or higher thresholds for hot and cold temperatures, you
can specify your own ranges.

Call the Image-Setting Method

In the convert method of TempController, call TempIimageView’s tempDidChange
method after converting the entered value:

public void convert (NSText Fi el d sender) {
if (sender == celsius) {
int f = (int)((9.0/5.0 * celsius.intValue()) + 32)
fahrenheit.setlntVal ue(f)
telse if (sender == fahrenheit) {
int ¢ = (int)((fahrenheit.intValue()-32) * 5.0/9.0)
cel si us. set | ntVal ue(c)
}
t enpl mage. t enpDi dChange(fahrenheit.intValue()); // add this
}
You must also add the tempImage outlet you defined earlier in Interface Builder as
an instance variable in TempController.java.
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COMPLETING THE APPLICATION

Add Images to the Project
Build the Project

Test Drive the Application

Add Images to the Project

The TemplmageView object must, of course, have images to show. Ready-made
“climate” images come provided for this tutorial. You must add these image files to
the application.

=

In Project Builder, double-click the Images category in the project browser.
2. Inthe Add Images panel, navigate to the following directory:

/System/Documentation/Developer/YellowBox/TasksAndConcepts/
JavaTutorial/Applicationlmages

If you are on a Yellow Box for Windows system, the above path starts with the
value of NEXT_ROOT rather than /System.

3. Add the following images: Hot.tiff, Cold.tiff, Moderate.tiff
Shift-click to select all images, then click OK to add them to the project.

4. Choose Save from the Project menu.
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Build the Project

Now you're ready to build the project. Click the Build button in the project window,
then the same button in the Build panel. You can circumvent these buttons by
pressing Command-Shift-B. If there are errors in the code, they will appear in the
two lower displays of the Build panel. Click a line describing an error in the upper
display to go to the line in the code containing the error; fix the error and rebuild.

Related concept: The Build Panel

Test Drive the Application

58

Launch the TemperatureConverter application and see what it can do; this includes
not only what you specifically programmed it to do, but the behavior the
application gets “for free.”

= Enter a low temperature value in the Fahrenheit field and press Return.

The Celsius field displays the converted temperature and the image changes to
the “cold” picture.

= Enter a high temperature value in the Celsius field and press Return.

The Fahrenheit field displays the converted temperature and the image changes
to the “hot” picture.

Now check out the “free” behavior.

= Click the window of another application or anywhere in the workspace.

The TemperatureConverter window loses key status (and as a result its title bar
loses its detail) and it might become tiered beneath other windows on your
screen. TemperatureConverter is no longer the active application.

» Click the TemperatureConverter window.

It is brought to the front tier of the window system and is made key.
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= Choose Hide TemperatureConverter from the Application menu (the menu at
the far right of the menu bar).

The TemperatureConverter window disappears from the screen.

= In the same Application menu, choose TemperatureConverter from the list of
applications currently running on your system.

The TemperatureConverter window reappears.

= Select anumber in one of the text fields, choose Copy from the Edit menu, select
the number in the other text field, and choose Paste from the Edit menu.

The number is copied from one field to the other.

= Select a number again and choose a suitable command from the Services menu,
such as Make Sticky.

The Services menu lists those applications that can accept selected data from
your application and process it in specific ways. When you choose a Services
command, the application associated with the command starts up (if it is not
already running) and processes the selected number. (In the case of Make Sticky,
the number appears in a Stickies window.)

= Chose Quit from the File menu.
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CREATING A SUBCLASS OF NSVIEW

1

Define a Custom Subclass of NSView

Implement the Code for a Custom NSView

Custom subclasses of NSView are ususally constructed differently than subclasses
of other Application Kit classes because the custom NSView subclass is responsible
for drawing itself and, optionally, for responding to user actions. Of course, you can
do custom drawing in a subclass that doesn’t inherit directly from NSView, but
usually instances of these classes draw themselves adequately. This section
describes in general terms what you must do to create a custom NSView subclass.

Define a Custom Subclass of NSView

The differences are slight between the Inteface Builder procedures for defining a
direct subclass of NSView and for defining a subclass of any Application Kit class
that inherits, directly or indirectly, from NSView. The following is a summary of the
required procedure in Interface Builder:

1.
2.
3.

Drag a CustomView object from the Views palette and drop it in the window.
Resize the CustomView object to the dimensions you would like it to have.

Select NSView in the Classes display of the nib file window, choose Subclass
from the Class menu, and name your subclass.

Add any necessary outlets or actions.
Assign the class you defined to the CustomView object.

Do this by selecting the object and selecting the class in the Classes display of the
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inspector.
6. Make any necessary connections.

7. Generate the “skeletal” .java file; before you choose the Classes>Create Files
command, be sure to select first the class and then Java in the Attributes display
of the inspector.

If you are unsure how to complete any of these steps, refer to the Defining the
Subclass and Connecting the View Object sections of this tutorial.

Implement the Code for a Custom NSView
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You can implement your custom NSView to do one or two general things: to draw
itself and to respond to user actions. The basic procedures for these and related
tasks are given below.

Important

The information provided in this section barely scratches
the surface of the concepts related to NSView, including
drawing, the imaging model, event handling, the view
hierarchy, and so on. This section intends only to give you
an idea of what is involved in creating a custom view. For
a much more complete picture, see the description of the
NSView class in the API reference.

Drawing

All objects that inherit from NSView must override the drawRect method to render
themselves on the screen. The invocation of NSView’s display method, or one of the
display variants, leads to the invocation of drawRect. Before drawRect is invoked,
NSView “locks focus,” setting the Window Server up with information about the
view, including the window device it draws in, the coordinate system and clipping
path it uses, and other PostScript graphics state information.

In the drawRect method, you must write the code that transmits drawing
instructions to the Window Server. The drawRect method has one argument: the
NSRect object defining the area in which the drawing is to occur (usually the
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bounds of the NSView itself or a subrectangle of it). The range of options the Java
Yellow Box APIs provide is currently more limited than on the Objective-C side,
which has the whole suite of PostScript client-side functions and operators. For
drawing in Java, you can use the following classes:

= NSBezierPath offers methods for constructing straight or curved lines,
rectangles, ovals, arcs, and polygons with bezier paths.

= NSAffineTransforms has methods for translating, rotating, and resizing
graphical objects, such as those created with NSBezierPath.

= The static methods of the NSGraphics class draw rectangles, including buttons
of various styles. They also perform bitmap operations and provide various
information about the Window Server and graphics context.

= Foundation’s geometry classes—NSRect, NSSize, and NSPoint (and their
mutable variants)—help you to compute the location and size of graphical
objects.

= NSColor and NSFont, for example, have methods that directly set a parameter
of the current graphics context.

Invalidating the View

With each cycle of the event loop, the Window Server ensures that each NSView in
a window that requires redrawing is given an opportunity to redisplay itself.
Besides implementing drawRect to draw your custom NSView, your application
must indicate that an NSView requires redrawing when data affecting the view
changes.

This indication is called “invalidation.” Invalidation marks an entire view or a
portion of a view as “invalid,” and thus requiring a redisplay. NSView defines two
methods for marking a view’s image as invaliekNeedsDisplay, which invalidates
the view’s entire bounds rectangle, ameheedsdisplayInRect, Which invalidates a
portion of the view.

You can also force an immediate redisplay of a view with the disp1ay and

displayRect methods, which are the counterparts to the methods mentioned above.
However, you should use these and relategiay... methods sparingly, and only
when necessary. Constant forced displays can markedly affect application perfor-
mance.

You should never invoke drawRect directly.
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Event Handling

If an NSView expresses a willingness to respond to user events, it is made the
potential recipient of any event detected by the window system. The view then just
must implement the appropriate NSResponder method (or methods) that
correspond to the event the view is interested in. (NSView inherits from
NSResponder.)

What this means in practical terms is that an NSView must at a bare minimum do
two things:

s Override NSResponder’s acceptsFirstResponder method to return true.

= Implement an NSResponder method such as mouseDown, mouseDragged, Or keyUp.
The argument of each of these methods is an NSEvent, which provides
information related to the event.

See the NSResponder and NSEvent class descriptions in the API reference for
further information.

An Example

The TemperatureView class is similar to the TemplmageView class implemented in
the second part of the tutorial. Instead of displaying a different image when the
temperature changes to a certain range, it draws a circle of a different color. To
illustrate basic event handling, the TemperatureView class changes the thickness of
the view’s border each time the user clicks the view.

/* TemperatureView */

import com.apple.yellow.application.*;
import com.apple.yellow.foundation.*;

public class TemperatureView extends NSView {
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protected NSBezierPath sun;
protected int temperature;
protected int thickness;

static public final int SpringSun=0;
static public final int SummerSun=1;
static public final int WinterSun=2;
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public TemperatureView(NSRect frame) {
super(frame);

float shortest = frame.width() >= frame.height()?frame.height():frame.width();
NSRect rect;
NSColor color;

shortest *= 0.75;
rect = new NSRect(((frame.width() - shortest) /2),
((frame.height() - shortest) /2), shortest, shortest);

sun = NSBezierPath.bezierPathWithOvalInRect(rect);

thickness = 1;

public void drawRect(NSRect frame) ({
NSColor color;
if (temperature == WinterSun) ({
color = NSColor.lightGrayColor();
} else if (temperature == SummerSun) {
color = NSColor.orangeColor();
} else {
color = NSColor.yellowColor();
}
color.set();
sun.fill();
NSGraphics.frameRectWithWidth(frame, (float)thickness);

public void tempDidChange(int degree) {
if (degree < 45) {
temperature = WinterSun;
} else if (degree > 75) {
temperature = SummerSun;
} else temperature = SpringSun;
setNeedsDisplay(true);

public void mouseDown(NSEvent e) {
if (thickness == 3) {
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thickness = 1;
b oelse |

thickness++;
}
setNeedsDisplay(true);

public boolean acceptsFirstResponder() f{
return true;
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DEVELOPING JAVA
APPLICATIONS—CONCEPTS

This document presents the concepts related to the tutorial Developing
Java Applications: A Tutorial.

Rhapsody’s Java Feature (Developer Release)

With the Rhapsody development environment, you can create
applications written in Java™ but built both from objects in the Yellow
Box frameworks and from pure Java objects. These applications run on
any Rhapsody or Yellow Box for Windows system.

There are four major parts to Rhapsody’s Java feature for this release:

= Java virtual machine (VM). This is the Java “runtime,” an interpreter
that loads Java class files and interprets the bytecode. The VM is
packaged in a framework (JavaVM.framework) which also includes
the latest version of JavaSoft’s JDK and a copy of JavaSoft’s reference
documentation.

= Java bridge. This technology links the Java programmatic interfaces
of Yellow Box classes and interfaces with their Objective-C
implementations. It makes it possible for developers to “wrap” their
Objective-C classes in Java APIs. Currently, most Yellow Box classes
are “wrapped.”

The Rhapsody development environment includes project types and
tools for wrapping Obijective-C code in Java interfaces. For more on
Apple’s bridging technology, see The Java Bridge.
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= New Java classes. Apple has developed several new, unbridged, Java
classes—both Yellow Box and native Java—primarily to resolve
“unbridgable” differences between the languages. Some of these
classes perform class loading, while others provide object wrappers
for Objective-C structures.

= Tools integration. Project Builder integrates the Java compiler

(javac), debugger (jdb), and packaging technology (creation of .jar or
.zip files). During a build, Project Builder handles source-code files in
a project appropriately, according to their extensions. Project Builder
also features a beta version of the debugger that allows you to debug
Java and Obijective-C code simultaneously. Interface Builder
incorporates a few Java features (for instance, definition of subclasses
of java.lang.0bject) and more are planned for upcoming releases.

Rhapsody also helps you build and lets you run 100% Pure Java™ applets
and applications. See Developing 100% Pure Java Applications for
details.

Bridging eventually will be supplanted by native implementation of the
Yellow Box frameworks in Java. You will also find that the development
environment soon will more completely integrate Java. For example,
Interface Builder will list all Yellow Box Java classes and will generate
appropriate Java code when it creates files. Project Builder’s debugger
will also handle Java debugging in a more sophisticated fashion.

The Java Bridge
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The Java bridge is an Apple technology that lets Objective-C objects and
Java objects communicate freely. With it developers can transparently
instantiate Objective-C objects in Java code and treat them as if they were
Java objects; for example, it allows Objective-C protocols to appear in the
guise of Java interfaces. Conversely, it can expose any Java class or
interface as an Objective-C class or protocol.

The core Yellow Box frameworks—the Application Kit and Foundation—
have been “bridged” to Java. This means that developers can write
Yellow Box applications using nothing but Java code.
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The Java bridge offers the following features:

= It exposes Objective-C classes as Java classes that can be directly
subclassed.

= Java objects are passed across the bridge to the Objective-C world
where they are manipulated by the code as if they were Objective-C
objects. (This happens whether the object is an instance of a 100% Pure
Java object or not.)

= Some Java classes, such as String and Exception, are mapped to
Objective-C classes, such as NSString and NSException; objects of
these classes are transparently “morphed” into each other as they
cross the bridge between the Java and Objective-C worlds.

= Developers need not worry whether a class comes from the Java or the
Objective-C world. The bridge transparently loads any needed
Objective-C framework whenever a bridged class is used.

The Rhapsody development environment provides a set of tools and
specifications that enable you to bridge your own Obijective-C classes and
protocols, exposing them as Java classes and interfaces. (And, if you wish,
you can expose Java classes and interfaces as Objective-C classes and
protocols.) The essential tool, bridget, reads and processes a “jobs” file —
a file with an extension of .jobs (the letters of which stand for Java to
Obijective-C Bridging Specification). The jobs file is a text file that contains
specifications mapping Objective-C classes, interfaces, and method
selectors to Java classes, interfaces, and methods.

Other tools in the development environment facilitate the process of
bridging frameworks. The general procedure for bridging is as follows:

1. Create a project in Project Builder that is of type JavaWrapper.

2. Create the jobs file. A demo application, Wraplt, assists developers
with this task.

3. Build the project. Project Builder and bridget use the jobs file to
generate Java classes and a dynamic library providing the
implementation of the native methods these classes declare.
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Developing 100% Pure Java Applications

70

You can use the Rhapsody development environment to develop 100%
Pure Java applications: that is, applications developed exclusively with
JavaSoft’s Java Development Kit (JDK). Rhapsody includes the latest
version of the JDK in

/System/Library/Frameworks/JavaVM. framework.

To create an 100% Pure Java application with the Rhapsody development
environment:

a > w NP

Launch Project Builder.

Choose New from the Project menu.

Select the Java Package project type from the pop-up menu.
Specify a directory location for your application.

For each .java file in your project:

1. Choose New in Project from the File menu.

2. In the New panel select the Classes suitcase, name the file, and
give it an extension of .java. Make sure that the Include Header
checkbox is not selected.

3. Click OK to add the file to the Classes category of the project.

Write the Java code needed to implement your project (you can
remove the lines importing the Yellow Box packages).

Project Builder supports syntax coloring and indentation for Java
code. You can use all other Project Builder features that do not depend
on project indexing.

Build the project. As with Objective-C projects, this merely requires
you to choose Tools>Build>Build Project.

The build process automatically invokes javac with the correct
arguments and does whatever else is requred to build the project, such
as creating the archive (a .zip file, by default). If there are Java coding
errors, Project Builder reports them in its Build panel; you can
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navigate to the code containing an error by clicking the reporting line
in the panel.

8. When you’re ready to create and install the .zip package containing
your Java class, do the following:

1. Chose the Build Attributes display of the Project Inspector and
examine the path in the Install In field.

If the default installation location is not what you want, change it.

Chose Tools>Project Build>Show Panel.

2

3

4. Open the Build inspector by clicking the checkmark button.

5. Change the selected item in the Target pop-up menu to “install”.
6

Click the Build button.

You can use the Java interpreter (java) and the applet previewer
(appletviewer) to run Java applications and applets, respectively. These
tools are in /usr/bin.

Important

To compile and run Java applicatons, the
CLASSPATH environment variable must be
correctly set. This variable is usually set for you
by the installation script and by Project Builder.
But if CLASSPATH becomes faulty, you can
reset it with the setenv and javaconfig
commands on the command line:

ffsetenv CLASSPATH .:“javaconfig DefaultClasspath®

A Project Window

Project Builder presents the elements of a project in a project window.
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Control panel (in order):

Project
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category
("suitcase")

Project Build, Project Find, Project Inspector, Launch/Debug, Context Help
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When you create or open a project, after some seconds you may notice

triangular “branch” buttons appearing after source code files in the

browser. Project Builder has indexed these files.

During indexing, Project Builder stores all symbols of the project (classes,

methods, globals, and such) in virtual memory. This allows Project
Builder to access project-wide information quickly. Indexing is
indispensable to such features as name completion and Project Find.
Usually indexing happens automatically when you create or open a

project. You can turn off this option if you wish. Choose Preferences from
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the Edit menu and then choose the Indexing display. Turn off the “Index
when project is opened” checkbox.

You can also index a project at any time by choosing
Tools>Indexer>Index Subproject. If you want to do without indexing
(maybe you have memory constraints), choose Tools>Indexer>Purge
Indices.

What’s a Nib File?

Every application has at least one nib file. The main nib file contains the
application menu and often a window and other objects. An application
can have other nib files as well. Each nib file contains the following
information:

Archived objects. Encoded information on Yellow Box objects, including
their size, location, and position in the object hierarchy (for view objects,
determined by superview/subview relationship). At the top of the
hierarchy of archived objects is the File’s Owner object, a proxy object that
points to the actual object that owns the nib file.

Custom class information. Interface Builder can store the details of
Yellow Box objects and objects that you palettize (static palettes), but it
does not know how to archive instances of your custom classes since it
doesn’t have access to the code. For these classes, Interface Builder stores
a proxy object to which it attaches class information.

Connection information. Information about how objects within the
object hierarchy are interconnected. Connector objects special to Interface
Builder store this information. When you save the document, connector
objects are archived in the nib file along with the objects they connect.

Images and sounds. Image files and sound files that you drag and drop
over the nib file window or over an object that can accept them (such as a
button or image view).
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Figure B-1 Contents of a nib file
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When You Load a Nib File

In your code, you can load a nib file by sending the NSBundle class
loadNibNamed:owner: Or ToadNibFile:externalNameTable:withZone:
messages. When you do this, the runtime system does the following: It
unarchives the objects from the object hierarchy, sending each object an
initWithCoder: message after allocating memory for it.

= It unarchives each proxy object and queries it to determine the
identity of the class that the proxy represents. Then it creates an
instance of this custom class and frees the proxy.

= It unarchives the connector objects and allows them to establish
connections, including connections to File’s Owner.

» Itsends awakeFromNib to all objects that were derived from
information in the nib file, signalling that the loading process is
complete.
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Connections and Accessor Methods

When Rhapsody establishes connections during the course of loading a
nib file, it sets the values of the source object’s outlets. It first tries to set
an outlet through the “set” accessor method if the source object
implements it. For example, if the source object has an outlet named
“contraption,” the system first sees if that object responds to
“setContraption” and, if it does, it invokes the accessor method. If the
source object doesn’t implement the accessor method, the system sets the
outlet directly.

Problems naturally ensue if a “set” accessor method does something
other than directly set the outlet. One common example is an accessor
method that sets the string value of an outlet referring to a text field
(setStringValue). After loading, the value of the outletis nu11 because the
“set” accessor method did not directly assign the value.

The Windows of Interface Builder

When you open a nib file, Interface Builder opens several windows: the
nib file window, a menu bar panel, a palette window, and an empty
window in which you can put elements of a graphical user interface. The
nib file window gives access to the objects, class definitions, and
resources of a nib file. The menu panel allows you to constuct your
application menus. And the palette window holds various objects of the
Application Kit and any custom objects that you or third parties palettize.
To show a palette, click on the of the icons that runs across the top of the
window.

Not shown in the illustration below is Interface Builder’s Inspector
(Tools>Inspector), which lets you set attributes and the size of objects,
specify objects to be connected, identify help files, and set many other
project attributes.
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Figure B-2 The standard windows of Interface Builder
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The View Hierarchy and the First Responder

Just inside each window’s content area—the area enclosed by the title
bar and the other three sides of the frame—is the *“content view.” The
content view is the root (or top) NSView in a window'’s view hierarchy.
Conceptually like a tree, one or more NSViews may branch from the
content view, one or more other NSViews may branch from these
subordinate NSViews, and so on. Except for the content view, each
NSView has one (and only one) NSView above it in the hierarchy. An
NSView’s subordinate views are called its subviews; its superior view is
known as the superview.

On the screen, enclosure determines the relationship between superview
and subview: a superview encloses its subviews. This relationship has
several implications for drawing:

= Subviews are positioned in the coordinates of their superview, so
when you move an NSView or transform its coordinate system, all
subviews are moved and transformed in concert.

= It permits construction of a superview simply by arrangement of
subviews. (An NSBrowser object is an instance of a compound
NSView.)

= Because an NSView has its own coordinate system for drawing, its
drawing instructions remain constant regardless of any change in
position in itself or of its superview.

The view hierarchy also affects how events are handled, particularly
through the first-responder mechanism.
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Figure B-3 A view hierarchy
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The diagram above shows how NSApplication, NSWindow, and NSView
objects are connected through their instance variables.

First Responder and the Responder Chain

Each NSWindow in an application keeps track of the object in its view
hierarchy that has “first responder” status. The first responder is the
NSView that currently is the focus of keyboard events in the window. By
default, an NSWindow is its own first responder, but any NSView within
the window can become first responder when the user clicks it with the
mouse.

You can also set the first responder programmatically with the
NSWindow’s makeFirstResponder: method. Moreover, the
first-responder object can be a target of an action message sent by an
NSControl, such as a button or a matrix. Programmatically, you do this by
sending setTarget: to the NSControl (or its cell) with an argument of ni1.
You can do the same thing in Interface Builder by making a target/action
connection between the NSControl and the First Responder icon in the
Instances display of the nib file window.

All NSViews of an application, as well as all NSWindows and the
application object itself, inherit from NSResponder, which defines the
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default message-handling behavior: events are passed up the responder
chain. Many Application Kit objects, of course, override this behavior, so
events are passed up the chain until they reach an object that does
respond.

The series of next responders in the responder chain is determined by the
interrelationships between the application’s NSView, NSWindow, and
NSApplication objects). For an NSView, the next responder is usually its
superview; the content view’s next responder is the NSWindow. From
there, the event is passed to the NSApplication object.

For action messages sent to the first responder, the trail back through
possible respondents is even more detailed. The messages are first passed
up the responder chain to the NSWindow and then to the NSWindow’s
delegate. Then, if the previous sequence occurred in the key window, the
same path is followed for the main window. Then the NSApplication
object tries to respond, and failing that, it goes to NSApp’s delegate.

The Target/Action Paradigm

Interface Builder allows you to view and specify connections between a
control object and its target in the Connections display of the control’s
inspector. The relation of target and action in this Inspector might not be
apparent. First, target is an outlet of a cell object that identifies the
recipient of an action message. So what is a cell object and what does it
have to do with a button?

One or more cell objects are always associated with a control object (that
is, an object inheriting from NSControl, such as a button). Control objects
“drive” the invocation of action methods, but they get the target and
action from a cell. This way one control object, such as an NSMatrix, can
have different targets and actions for each of its cells, as well as its own
target and action. NSActionCell defines the target and action outlets, and
most kinds of cells in the Application Kit inherit these outlets.

When a user clicks a button, the button gets the target and action
information from its cell. The action is a selector indicating the method to
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invoke in the target object. The button sends the approriate message to its
target, which is typically an instance of a custom class.

Figure B-4 Target and action in Interface Builder
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The Actions column of the Connections display shows the action
methods defined by the class of the target object and known by Interface
Builder. Interface Builder identifies action methods because their
declarations follow the syntax:

- (IBAction)doThis:(id)sender;

The return argument can also be void instead of 1BAction, but the
argument is always sender.
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Model-View-Controller Paradigm

A common and useful paradigm for object-oriented applications,
particularly business applications, is Model-View-Controller (MVC).
Derived from Smalltalk-80, MVC proposes three types of objects in an
application, separated by abstract boundaries and communicating with
each other across those boundaries.

Model object. This type of object represents special knowledge and
expertise. Model objects hold a company’s data and define the logic that
manipulates that data. For example, a Customer object, common in
business applications, is a Model object. It holds data describing the
salient facts of a customer and has access to algorithms that access and
calculate new data from those facts. A more specialized Model class
might be one in a meteorological system called Front; objects of this class
would contain the data and intelligence to represent weather fronts.
Model objects are not directly displayed. They often are reusable,
distributed, persistent, and portable to a variety of platforms.

View object. A View object in the paradigm represents something visible
on the user interface (a window, for example, or a button). A View object
is “ignorant” of the data it displays. The Application Kit usually provides
all the View objects you need: windows, text fields, scroll views, buttons,
browsers, and so on. But you might want to create your own View objects
to show or represent your data in a novel way (for example, a graph
view). You can also group View objects within a window in novel ways
specific to an application. View objects, especially those in kits, tend to be
very reusable and so provide consistency between applications.

Controller object. Acting as a mediator between Model objects and View
objects in an application is a Controller object. There is usually one per
application or window. A Controller object communicates data back and
forth between the Model objects and the View objects. It also performs all
the application-specific chores, such as loading nib files and acting as
window and application delegate. Since what a Controller does is very
specific to an application, it is generally not reusable even though it often
comprises much of an application’s code. (This last statement does not
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mean, however, that Controller objects cannot be reused; with a good
design, they can.)

Because of the Controller’s central, mediating role, Model objects need
not know about the state and events of the user interface, and View
objects need not know about the programmatic interfaces of the Model
objects. You can make your View and Model objects available to others
from a palette in Interface Builder.

Hybrid models. MVC, strictly observed, is not advisable in all
circumstances. Sometimes it’s best to combine roles. For instance, in a
graphics-intensive application, such as an arcade game, you might have
several View objects that merge the roles of View and Model. In some
applications, especially simple ones, you can combine the roles of
Controller and Model; these objects join the special data structures and
logic of Model objects with the Controller’s hooks to the interface.

The Build Panel
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The Project Build panel has buttons that do the following:

= Initiate the build process.
» Delete the products of the last build(“make clean”).
= Let you set options for the build.

It also shows the results of the build and takes you to the site of any error
in the code when you click the line in the Project Build panel reporting the
error.



A PPENDIX B

Panel controls: Build, Make Clean, Options

1 error

Target: appwith args ™’ |
Status: TemperatureConverter.app - Build failed (1 error)

Error summary
(click line to go to
code site)

Build detail
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